apt-get, Nichterfüllte Abhängigkeiten

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von RoughlY, 06.05.2008.

  1. #1 RoughlY, 06.05.2008
    RoughlY

    RoughlY Grünschnabel

    Dabei seit:
    06.05.2008
    Beiträge:
    6
    Zustimmungen:
    0
    Jetzt habe ich endlich ein Linux gefunden, was auf meinem recht alten Notebook läuft und schon habe ich das erste Problem.
    Ich benutze zurzeit Knoppix 5.1 allerdings auf der Festplatte installiert mit KDE.
    So,mein Problem ist, dass das doch sehr praktische apt-get nicht mehr laufen will.

    Ich muss dazu sagen, dass ich ein ziemlicher neuling bin, was Linux angeht.

    Ich will etwas installieren und dann kommt Folgendes:

    Code:
    apt-get install gksu
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Probieren Sie »apt-get -f install«, um diese zu korrigieren:
    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
      binutils-dev: Hängt ab: binutils (= 2.18.1~cvs20080103-4) aber 2.17-3 soll installiert werden
      gksu: Hängt ab: libatk1.0-0 (>= 1.20.0) aber 1.12.3-1 soll installiert werden
            Hängt ab: libc6 (>= 2.6.1-1) aber 2.3.6.ds1-8 soll installiert werden
            Hängt ab: libcairo2 (>= 1.4.0) aber 1.2.4-4 soll installiert werden
            Hängt ab: libglib2.0-0 (>= 2.14.0) aber 2.12.4-2 soll installiert werden
            Hängt ab: libgnome-keyring0 (>= 2.20.1) aber 0.6.0-3 soll installiert werden
            Hängt ab: libgtk2.0-0 (>= 2.12.0) aber 2.8.20-3 soll installiert werden
            Hängt ab: libpango1.0-0 (>= 1.18.3) aber 1.14.8-4 soll installiert werden
      locales: Hängt ab: glibc-2.7-1
    E: Nichterfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne jeglich Pakete (oder geben Sie eine Lösung an).
    
    Ich weiß, dass es so einen Thread schon gibt, nur hatte sich da das Problem (zum glück X( ) einfach so gelöst nach ein paar Tagen. In der hoffnung warte ich jetzt auch schon 4 Tage aber es hat sich noch nicht gebessert.

    Das Problem besteht seit (wie ich denke, aber nicht weiß) ich eine Installation von Psi dummerweise abgebrochen hatte. Vielleicht hat das ja damit etwas zutun.

    Danke und freundliche Grüße,

    Ben!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 06.05.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Na dann befolge doch einfach mal den Tip deines freundlichen Systems:

    Code:
    apt-get -f install
    .....:devil:

    Am besten vorher noch ein

    Code:
    apt-get clean
    apt-get update
     
  4. #3 RoughlY, 06.05.2008
    RoughlY

    RoughlY Grünschnabel

    Dabei seit:
    06.05.2008
    Beiträge:
    6
    Zustimmungen:
    0
    an sich eine logische idee.
    Ich habe nur vergessen zu erwähnen, dass man somit die selbe fehlermeldung erhält.
    auch mit apt-get clean und einem erneuten update.
     
  5. #4 supersucker, 06.05.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Von woher hast du denn binutils installiert?

    Wahrscheinliche Lösung des Problems:

    • deinstallierte binutils
    • installiere binutils Version 2.17-3 (also die von apt-get angebotene)
    • lass nochmal ein "apt-get -f install durchlaufen
     
  6. #5 RoughlY, 06.05.2008
    Zuletzt bearbeitet: 06.05.2008
    RoughlY

    RoughlY Grünschnabel

    Dabei seit:
    06.05.2008
    Beiträge:
    6
    Zustimmungen:
    0
    das habe ich nicht wissend installiert, warscheinlich einfach beim setup mit draufgekommen.

    Ich wills mal versuchen, aber wie installiere ich das, wenn binutils unten ist?

    Also geht das dann über apt-get noch?

    Danke schonmal
     
  7. #6 supersucker, 06.05.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Naja,

    das hier

    sieht für mich so aus als hättest du "unsaubere" Quellen verwendet.

    Löschen mit

    Code:
    dpkg --purge binutils
    notfalls mit

    Code:
    dpkg --purge binutils --force-all
    Dann ein

    Code:
    aptitude -f install
     
  8. #7 RoughlY, 06.05.2008
    RoughlY

    RoughlY Grünschnabel

    Dabei seit:
    06.05.2008
    Beiträge:
    6
    Zustimmungen:
    0
    Hmmm...unlogische fehlermeldung nummer 2:

    Code:
    dpkg --purge binutils --force-all
    dpkg: Abhängigkeitsprobleme verhindern Entfernen von binutils:
     debootstrap hängt ab von binutils.
     tiger hängt ab von binutils.
     chkrootkit hängt ab von binutils.
     gcc-4.1 hängt ab von binutils (>= 2.16.1cvs20051214).
     dpkg-dev hängt ab von binutils; aber:
      Paket binutils soll entfernt werden.
     debhelper hängt ab von binutils.
    dpkg: Fehler beim Bearbeiten von binutils (--purge):
     Abhängigkeitsprobleme - entferne nicht
    dpkg - Warnung: Ignoriere den Wunsch, --force-all zu entfernen; es ist nicht installiert.
    Fehler traten auf beim Bearbeiten von:
     binutils
    
    was nun? -.-
     
  9. towo

    towo Haudegen

    Dabei seit:
    16.05.2003
    Beiträge:
    649
    Zustimmungen:
    1
    Ort:
    Pößneck
    Ein "richtiges" Debian benutzen, anstatt dieses unsauberen Knoppix-Mischmaschs aus allen möglichen Quellen, incl. Ubuntu.
     
  10. #9 supersucker, 06.05.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    1.

    * Zustimm * @ towo

    2.

    Wirst du jetzt wohl in den sauren Apfel beißen müssen:

    Die oben angemahnten Abhängigkeiten Stück für Stück deinstallieren müssen, solange bis das Entfernen von binutils klappt.
    Dann * dringend * deine Paket-sourcen in Ordnung bringen.
    Dann nochmal apt-get durchlaufen lassen.

    Wenn du Glück hast, reicht auch schon das hier:
     
  11. #10 RoughlY, 06.05.2008
    RoughlY

    RoughlY Grünschnabel

    Dabei seit:
    06.05.2008
    Beiträge:
    6
    Zustimmungen:
    0
    gibt es denn ein debain (sorry wegen der jetzt warscheinlich dummen frage :) )
    das einen KDE und etwas software direkt beinhaltet oder soll ich da auf kanotix gehen?

    ich muss dazu sagen, dass mein rechner das knoppix gerade so verkraftet:

    IntelPentium 3 600MHz
    128 MB SODIMM SD RAM
    und 6gb festplatte

    und ja ich weiß, ein neuer ist schon in arbeit.

    MfG
     
  12. #11 Goodspeed, 06.05.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Versuchs erstmal mit
    Code:
    apt-get install binutils=2.17-3
    
     
  13. #12 RoughlY, 06.05.2008
    RoughlY

    RoughlY Grünschnabel

    Dabei seit:
    06.05.2008
    Beiträge:
    6
    Zustimmungen:
    0
    gleiche fehlermeldung. naja, ihr habt wohl recht damit, dass knoppix einfach nicht als haupt-OS gedacht ist. Das merkt man ja schon beim booten, ehe der die hardware erkannt hat, war ich schon drei mal beim internetcafé. xD ich werde jetzt erstmal xubuntu ausprobieren und hoffe, dass ich damit zufrieden bin. Trotzdem vielen Dank für Eure Anteilnahme!
     
  14. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. Dvergr

    Dvergr Tripel-As

    Dabei seit:
    10.10.2006
    Beiträge:
    180
    Zustimmungen:
    0
    Ja: http://www.debian.org

    Installiert standardmäßig zwar Gnome, aber KDE lässt sich problemlos mit APT nachinstallieren. Die sauberste Lösung wäre natürlich, nur ein Standardsystem ohne grafische Oberfläche zu installieren, und dann direkt über die Shell KDE zu installieren. Aber wir wollen ja nicht zu viel auf einmal machen ;)

    Generell hast du mit Debian wohl eine der umfangreichsten Distributionen, was das Softwareangebot aus Standardsourcen angeht.
     
  16. #14 gropiuskalle, 06.05.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    KDE ganz schnell vergessen, allerallerwenigstens 256MB RAM sollte man dafür bereit halten, ab 512 läuft es erst wirklich okay. Mit der Kiste sollten aber WMs wie Fluxbox oder Xfce noch gut laufen. Prinzipiell kannst Du jeden WM auf jeder Distri nachinstallieren (oder sogar von vornherein als default festlegen).
     
Thema: apt-get, Nichterfüllte Abhängigkeiten
Besucher kamen mit folgenden Suchen
  1. ubuntu nicht erfüllte abhängigkeiten

    ,
  2. apt hängt ab von aber ubuntu soll installiert werden

    ,
  3. linux nicht erfullte abhängigkeiten

Die Seite wird geladen...

apt-get, Nichterfüllte Abhängigkeiten - Ähnliche Themen

  1. apt-get Problem mit nichterfüllten Abhängigkeiten ...

    apt-get Problem mit nichterfüllten Abhängigkeiten ...: hallo, habe ein Problem mit apt-get hier ein Beispiel, das wohl selbsterklärend ist... debian:/home/userx# apt-get install ripperx...
  2. Problem bei apt-get upgrade (Kali 2.0)

    Problem bei apt-get upgrade (Kali 2.0): Hi, seit paar Tagen habe ich einige Probs. Dachte es sei mal an der Zeit für ein Update und nun tauchen da einige Fehler auf: Es müssen noch 0 B...
  3. apt-get in ein verzeichnis runterladen

    apt-get in ein verzeichnis runterladen: Hallo Ich möchte eine datei "liblept.so" mit apt-get nicht installieren sondrn in ein lokales Verzeichnis downloaden geht das? Gruß
  4. Folgen von apt-get rückgängig machen...?

    Folgen von apt-get rückgängig machen...?: hallo zusammen habe gerade auf eineme debian 5.0.10 den vlc-player der version 6.0.5 installiert. es wurden run 600mb (!!!) heruntergeladen,...
  5. debian lenny updaten per apt-get?

    debian lenny updaten per apt-get?: hallo zusammen habe auf meinem sparc-rechner nun wieder debian lenny installiert, da das besser läuft als "squeeze" und "wheezy". nun wollte...