Apache2 not running

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von hitman, 03.09.2006.

  1. hitman

    hitman Jungspund

    Dabei seit:
    15.10.2003
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo Leute,

    habe folgendes Problem,

    nach dem ich meinem Apache2 Server neugestartet habe erhalte ich folgende Meldung! httpd (pid 5100?) not running
    Das ganze passierte nach Erstellung einer VirtualHost.?(

    jemand eine Idee, wäre echt dankbar dafür:D
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Dazu muesstest du uns mal sagen, was du an der Konfiguration geaendert hast. Wobei du diesen Fehler eigentlich dadurch beseitigen kannst, dass du nicht 'restart' als Option fuer's init-Skript nutzt, sondern 'start' und vorher die PID-Datei des Webservers loescht. Sollte er dann nicht starten, hast du wohl einen Fehler in deine Konfiguration eingebaut und um den zu beheben braeuchten wir 1. die Aenderungen, die du an deiner Konfiguration gemacht hast und 2. die fuer den Webserver-Start relavanten Log-Abschnitte.
     
  4. grey

    grey -=[GHOST]=-

    Dabei seit:
    28.07.2006
    Beiträge:
    303
    Zustimmungen:
    0
    Ich lasse nach jeder Änderung an der Apache2-Config einen Check durchlaufen.

    Gib als root folgendes in der Console ein (keine Ahnung, ob das Script bei dir installiert ist)
    Code:
    mod-001:~# apache2ctl -t
     
  5. hitman

    hitman Jungspund

    Dabei seit:
    15.10.2003
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo,

    danke schon mal für die Meldung, habe den Fehler in der Änderung gefunden:

    ich habe in der httpd-vhosts.conf meine eigenen Logs definiert und dabei ist es wohl passiert.

    :rtfm: Fehler: /
    ErrorLog /var/www/meinehomepagelogs/home-error_log
    CustomLog /var/www/meinehomepagelogs/home-access_log common

    geändert:
    ErrorLog /var/www/meinehomepage/logs/home-error_log
    CustomLog /var/www/meinehomepage/logs/home-access_log common

    Danach /usr/local/apache2/bin/apache2 start und fertig.
    Keine Fehlermeldung:D
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Apache2 not running

Die Seite wird geladen...

Apache2 not running - Ähnliche Themen

  1. Apache2 mod_proxy

    Apache2 mod_proxy: Hallo Gemeinde, ich raff es einfach nicht. Ich habe mir den Apache2-Server als Proxy eingerichtet, damit ich mir hinter meiner Firewall über...
  2. Newbie:apache2/befehl htdigest Problem

    Newbie:apache2/befehl htdigest Problem: Hallo Leute, ich habe ein Problem mit diesem Befehl: htdigest -c /etc/apache2/passwords xxxxx xxxxx xxxx= usernamen sollen eingefügt werden...
  3. apache2: Virtualhost ohne subdomain

    apache2: Virtualhost ohne subdomain: Hi, ich möchte bei apache einen virtualhost für fqdn.de/testname einrichten. Folgendes habe ich (unter Anderem) in der entsprechenden Datei im...
  4. Problem mit Apache2 + MySQL Server

    Problem mit Apache2 + MySQL Server: Guten Mittag allen zusammen, ich möchte nun in ein Forum nachfragen bezüglich meines Problemes da ich leider derzeit einen Freund (der mir bisher...
  5. apache2 und ProxyPassReverse

    apache2 und ProxyPassReverse: Hey Leute, also irgendwas ist wieder im Busch :) vhost ausschnitt: ServerName fu.mydomain.com ProxyPass / http://localhost:7070/...