Apache - php5 Datei zum Download ??

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von elmalhi, 04.04.2007.

  1. #1 elmalhi, 04.04.2007
    elmalhi

    elmalhi Grünschnabel

    Dabei seit:
    04.04.2007
    Beiträge:
    5
    Zustimmungen:
    0
    Guten Tag zusammen,

    vielleicht kann mir jemand bei disem Problem helfen !!!
    Umgebung : Linux Fedora, PHP5.1.6 Apache 2.2.3

    ich möchte einen PHP-Script auszuführen aber eigentlich bekomme ich den File zum download .
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 lordlamer, 04.04.2007
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    php als cgi,fcgi oder modul im apache aktivieren
    browsercache löschen ;)

    frank
     
  4. dizzgo

    dizzgo Lernbereite Riesenratte

    Dabei seit:
    04.08.2005
    Beiträge:
    573
    Zustimmungen:
    0
    Ort:
    /ch/sg///
    Has du in deiner httpd.conf (oder apache.conf oder wie auch immer) folgendes eingetragen?
    Code:
    <IfModule mod_mime.c>
    application/x-httpd-php             php
    application/x-httpd-php-source      phps
    </IfModule>
    
    Gruss
    d22
     
  5. #4 elmalhi, 04.04.2007
    elmalhi

    elmalhi Grünschnabel

    Dabei seit:
    04.04.2007
    Beiträge:
    5
    Zustimmungen:
    0
    ja hab ich :

    IfModule mod_mime.c>
    application/x-httpd-php php
    application/x-httpd-php-source phps
    </IfModule>

    aber trotzdem no way
     
  6. dizzgo

    dizzgo Lernbereite Riesenratte

    Dabei seit:
    04.08.2005
    Beiträge:
    573
    Zustimmungen:
    0
    Ort:
    /ch/sg///
    Entschuldige die doofe Frage, aber das Modul hast du auch eingebunden:
    Code:
    LoadModule php5_module /usr/local/apache2/modules/libphp5.so
    
    und anschliessend den Apache neugestartet...

    Gruss
    d22
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 elmalhi, 04.04.2007
    elmalhi

    elmalhi Grünschnabel

    Dabei seit:
    04.04.2007
    Beiträge:
    5
    Zustimmungen:
    0
    vielleicht soll ich das auch aktivieren im "httpd.conf":
    LoadModule php5_module modules/libphp5.so
    aber :wenn ich das aktiviere bekomme ich diesen Fehlermeldung:
    httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory.

    und ich finde niergendwo diesen libphp5.so in meinem Rechner.

    Gruss und besten Dank.
     
  9. dmaphy

    dmaphy Routinier

    Dabei seit:
    16.04.2004
    Beiträge:
    482
    Zustimmungen:
    0
    Ort:
    Hamburg
    eventuell solltest du dann auch PHP auf deinem System installieren und ausserdem nicht Threads zum selben Thema an verschiedenen Orten erstellen... ich hab dir in deinem anderen Thread schon Hinweis genug auf die Lösung gegeben...
     
Thema:

Apache - php5 Datei zum Download ??

Die Seite wird geladen...

Apache - php5 Datei zum Download ?? - Ähnliche Themen

  1. apache2-mod_php5 will nicht.

    apache2-mod_php5 will nicht.: Hi, ich habe hier einen apache2 mit installiertem PHP5 und Apache-Modul unter SuSE 10. PHP selbst funktioniert zwar, jedoch spuckt mir der...
  2. PHP5.x + 5.3 parallel? (Apache, Debian)

    PHP5.x + 5.3 parallel? (Apache, Debian): Hi, ich wollte zum Testen auf meinen Webserver PHP5.3 installieren, damit ich die Seiten nach und nach umziehen kann, brauche aber für einige...
  3. Apache2 php5

    Apache2 php5: Ich habe ein suse 11.1 und über yast2 einen Apache2 mit PHP5 installiert. Die index.html öffnet er, eine index.php allerdings nicht. Bei der...
  4. Apache2 mit PHP4 und PHP5 (Debian Etch)

    Apache2 mit PHP4 und PHP5 (Debian Etch): Hallo, ich suche nun schon seit einiger Zeit im Internet eine gute Anleitung wie ich unter Debian Etch mit Apache2 mit der PHP-Version 4 und 5...
  5. opensue 10.2 apache worker +php5+mysql5 wo

    opensue 10.2 apache worker +php5+mysql5 wo: OpenSuse 10.2: apache worker +php5+mysql5 Hallo, schnelle Frage. Wenn ich Apache worker mpm statt prefork haben moechte, muss ich einfach...