Apache für lokale Web-Entwicklung einrichten

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von BeS, 12.03.2013.

  1. BeS

    BeS Grünschnabel

    Dabei seit:
    12.03.2013
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo,

    ich arbeite ein ein paar PHP Web-Anwendungen. Dafür möchte ich den Apache so einrichten, dass ich direkt die Anwendung testen kann. Die Anwendungen liegen in meinem Home-Verzeichnis, da ich auf den Daten täglich arbeite.

    Die Konfiguration sieht so aus:

    Code:
    Alias /app1 /home/bes/src/app1
    
    <Directory /home/bes/src/app1>
        Order Deny,Allow
        Deny from All
        Allow from None
    </Directory>
    
    Wenn ich auf die Seite zugreifen will bekomme ich aber ein Meldung, dass ich nicht die benötigten Rechte habe um auf das Verzeichnis zu zugreifen.

    Unter Debian war das bisher nie ein Problem, Fedora scheint hier strikter zu sein. Was muss ich machen, damit der Apache auf mein Entwicklungs-Verzeichnis zugreifen kann?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 HeadCrash, 12.03.2013
    HeadCrash

    HeadCrash Routinier

    Dabei seit:
    16.05.2009
    Beiträge:
    482
    Zustimmungen:
    1
    Ort:
    Bayern
    Wenn du alles und jeden Aussperrst ist das irgendwie klar :D

    Code:
        Deny from All
        Allow from None
    
    Versuchs mal mit 127.0.0.1 anstelle des None oder deiner IP in deinem LAN.

    mfg
    HeadCrash
     
  4. BeS

    BeS Grünschnabel

    Dabei seit:
    12.03.2013
    Beiträge:
    4
    Zustimmungen:
    0
    Hm, das "Allow from None" habe ich irgendwie ganz übersehen. Funktioniert aber leider weiterhin nicht. Egal ob ich eine IP Eintrage oder versuchsweise sogar "Allow from All".
     
  5. #4 HeadCrash, 12.03.2013
    HeadCrash

    HeadCrash Routinier

    Dabei seit:
    16.05.2009
    Beiträge:
    482
    Zustimmungen:
    1
    Ort:
    Bayern
    Darf der User unter welchem der Webserver läuft das Verzeichnis lesen?
     
  6. BeS

    BeS Grünschnabel

    Dabei seit:
    12.03.2013
    Beiträge:
    4
    Zustimmungen:
    0
    Das ist vermutlich das Problem. Ich habe das Verzeichnis schon testweise dem user "apache" zugeordnet -> keine Besserung. Wenn ich die Config so abändere, dass sie in ein Verzeichnis unter /var/www (dem default Verzeichnis von Apache unter Fedora) zeigt funktioniert es, diese Verzeichnisse gehören root. Ich könnte mir auch vorstellen, dass SELinux da mit rein spielt, will es aber nur sehr ungern deaktivieren.
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 Plinzen, 12.03.2013
    Plinzen

    Plinzen Foren As

    Dabei seit:
    11.04.2007
    Beiträge:
    96
    Zustimmungen:
    0
    Oh ja, damit hatte ich anfangs auch Probleme.

    Hast du die Berechtigungen geprüft?
    Falls ja, kann es noch an SELinux liegen:
    http://fedoraproject.org/wiki/SELinux/apache

    Dazu musst du den Context für dein Verzeichnis /home/bes/src/app1 ändern. Auf httpd_sys_content_t zum Beispiel.
    http://docs.fedoraproject.org/en-US..._SELinux-SELinux_Contexts_Labeling_Files.html

    Ein Tutorial hierzu findest du hier: http://diegobz.net/2010/03/07/enabling-apache-userdir-public_html-with-selinux-enabled-on-fedora/

    Ich hoffe das löst dein Problem. Ansonsten mal in /var/log/messages gucken. Da war bei mir das Problem und die Lösung immer recht ordentlich beschrieben.

    Viele Grüße!
     
  9. BeS

    BeS Grünschnabel

    Dabei seit:
    12.03.2013
    Beiträge:
    4
    Zustimmungen:
    0
    Ich habe jetzt SELinux mal auf 'permissive' gesetzt um fürs erste sicher zu gehen ob es wirklich ein SELinux Problem ist. Bekomme aber weiterhin die gleiche Fehlermeldung.

    Im Apache error log steht:

    Code:
    [Tue Mar 12 16:24:29.315705 2013] [authz_core:debug] [pid 1449] mod_authz_core.c(802): [client 127.0.0.1:51169] AH01626: authorization result of Require all denied: denied
    [Tue Mar 12 16:24:29.315775 2013] [authz_core:debug] [pid 1449] mod_authz_core.c(802): [client 127.0.0.1:51169] AH01626: authorization result of <RequireAny>: denied
    [Tue Mar 12 16:24:29.315783 2013] [authz_core:error] [pid 1449] [client 127.0.0.1:51169] AH01630: client denied by server configuration: /home/bes/src/app1
    
    Ich habe jetzt in meiner config noch ein:

    Code:
    Require all granted
    
    dazu genommen, damit funktioniert es. Ich bin mir aber noch nicht so sicher ob das die Musterlösung ist.
     
Thema:

Apache für lokale Web-Entwicklung einrichten

Die Seite wird geladen...

Apache für lokale Web-Entwicklung einrichten - Ähnliche Themen

  1. Support für Apache-Webserver 2.0 eingestellt

    Support für Apache-Webserver 2.0 eingestellt: Mit der Freigabe der Version 2.0.65 haben die Entwickler des populären Apache-Webservers die Pflege der alten Version 2.0 eingestellt. Anwender...
  2. Apache2 konfigurieren für mehrere Seiten

    Apache2 konfigurieren für mehrere Seiten: Hallo. Ich habe einen Webserver, den ich gerne für mehrere Internetseiten nutzen würde. Jede Webseite soll auch noch mehrere Subdomains haben....
  3. wie umsetzen: HA und LB Cluster für Apache und MySQL @ Debian ?

    wie umsetzen: HA und LB Cluster für Apache und MySQL @ Debian ?: Hallo, ich wende mich ans Forum, da bei mir noch etwas Unklarheit besteht. Problem: Ich soll eine Hochverfügbarkeitslösung für einen Cluster...
  4. Apache vhost, wo default host für http://ip eintragen?

    Apache vhost, wo default host für http://ip eintragen?: Hi, ich habe einen Apache Server auf dem mehrere Seiten laufen. Alles funktioniert auch prima. Nur suche ich die Einstellungsmöglichkeit für...
  5. Apache für nur eine Datei

    Apache für nur eine Datei: Hallo, ich würde gerne dem Apache einen Virtuellen Host zuweisen, der es nur erlaubt auf eine Datei in einem Verzeichnis zuzugreifen. Also...