Apache bzw. PHP Zeit

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von cstrasser, 27.03.2008.

  1. #1 cstrasser, 27.03.2008
    cstrasser

    cstrasser Grünschnabel

    Dabei seit:
    27.03.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Guten Abend!

    Habe ein kleines Problem:
    Zur Info: Habe Debian Etch 4.0

    Also wenn ich über PHP auf einer Seite die Zeit ausgebe dann ist sie immer um exakt eine Stunde hinten! wenn ich in der Konsole date eingebe, kommt aber die richtige Zeit!

    Weis jemand was man hier tun kann???
    in Google habe ich nichts gefunden!

    Dann habe ich noch ein kleines Problem:
    Was muss ich in die Apache config Datei schreiben, dass er mir auf Seiten, wo keine index Datei ist, eine Index of / Seite anzeigt??
    habe schon einiges versucht aber funktioniert hats noch nie!

    lg
    Christoph
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Code:
    <Directory /pfad/>
       Options Indexes
    </Directory>
    
    So zum Beispiel.
     
  4. #3 Gentfloo, 27.03.2008
    Gentfloo

    Gentfloo #470425

    Dabei seit:
    09.05.2007
    Beiträge:
    163
    Zustimmungen:
    0
    Ort:
    Hannover
    versuch mal in der php.ini:

    date.timezone = Europe/Berlin

    Sind die LANG und LC variablen richtig? (benutze kein Debian)
     
  5. #4 cstrasser, 27.03.2008
    cstrasser

    cstrasser Grünschnabel

    Dabei seit:
    27.03.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Habe ich schon! Funktionoiert aber nicht!
    (Bekomme im Browser noch immer die Fehlermeldung
    "You do not have permission to access this document.")

    Danke!
    Funktioniert jetzt!
     
  6. #5 Gentfloo, 27.03.2008
    Gentfloo

    Gentfloo #470425

    Dabei seit:
    09.05.2007
    Beiträge:
    163
    Zustimmungen:
    0
    Ort:
    Hannover
    Code:
          Order           allow,deny
          Allow           from all
    
    Versuchs mal damit, wenn's auch nicht funtzt, zeige am besten mal Deine configs.
     
  7. #6 cstrasser, 27.03.2008
    cstrasser

    cstrasser Grünschnabel

    Dabei seit:
    27.03.2008
    Beiträge:
    5
    Zustimmungen:
    0
    geht auch noch nicht!
    Also bei mir stehts so drinnen!

    <Directory "/usr/share/apache2/icons">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>
     
  8. #7 Always-Godlike, 27.03.2008
    Always-Godlike

    Always-Godlike Das Freak

    Dabei seit:
    31.12.2006
    Beiträge:
    939
    Zustimmungen:
    0
    Ort:
    Saarland
    Heißt es nicht "Options +Indexes" ? Oder gilt das als Trigger wenn kein Zeichen davor iss?
     
  9. #8 cstrasser, 28.03.2008
    cstrasser

    cstrasser Grünschnabel

    Dabei seit:
    27.03.2008
    Beiträge:
    5
    Zustimmungen:
    0
    nein!
    das is es auch nicht!

    puhhh....also als ich noch auf suse war ist das nicht so kompliziert gewesen!
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 Always-Godlike, 28.03.2008
    Always-Godlike

    Always-Godlike Das Freak

    Dabei seit:
    31.12.2006
    Beiträge:
    939
    Zustimmungen:
    0
    Ort:
    Saarland
    Guck dir mal den Directory an. Ich glaube deine Dateien/Ordner liegen wo anders. Der hier ist nur für die Icons die vom Apache genutzt werden.

    Da muss noch ein anderer Bereich mit <Directory> sein, wo dann auch die richtige Adresse drinne steht. Da muss die Option hin.

    Übrigens: Gewöhn dir die !! ab. Dein letzter Beitrag hat sich für mich beim ersten Lesen so angehört als würdest du mich anschreien weil mein Tipp dir nicht geholfen hat. Dann fiel mir auf, dass das bei fast jedem Satz machst. Man sollte sehr sparsam mit den !! umgehn und auch drauf achten wie diese Zeichen rüberkommen.

    Gruß Always-Godlike
     
  12. #10 cstrasser, 28.03.2008
    cstrasser

    cstrasser Grünschnabel

    Dabei seit:
    27.03.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Ohh...tut mir leid
    ich schreibe einfach gerne mit !!! und ??? und ...

    aber es war bestimmt nicht als anschreien oder böse gemeint.

    lg Christoph
     
Thema:

Apache bzw. PHP Zeit

Die Seite wird geladen...

Apache bzw. PHP Zeit - Ähnliche Themen

  1. Nach Apache Neustart Netzwerk-Zeitüberschreitung

    Nach Apache Neustart Netzwerk-Zeitüberschreitung: Hallo, durch ein Missgeschick von mir, musste ich nen Root Server im Recovery Modus von 1und1 reparieren. Danach hab ich den Server noch mals...
  2. Apache Logs zeigen Zeitverschiebungen

    Apache Logs zeigen Zeitverschiebungen: Moin, mein Apache Server reagiert seit kurzem teilweise nicht mehr, kurz vor einem Ausfall kann ich folgendes in den Logs erkennen:...
  3. Update auf Apache >=2.4.12 unter Debian Jessie

    Update auf Apache >=2.4.12 unter Debian Jessie: Hi, aufgrund eines Bugs in Apache 2.4 benötige ich zum Deployment von Seafile unter Debian Jessie das Paket apache2 in der Version >= 2.4.12...
  4. Centos und Apache (VirtualHost)

    Centos und Apache (VirtualHost): Hallo, ich bin gerade dabei die Firmenseiten unserer Unternehmensgruppe neu zu gestalten. Insgesammt sind es 3 Unternehmen. Als Server wurde mir...
  5. Apache Software Foundation gibt sich neues Logo

    Apache Software Foundation gibt sich neues Logo: Die Apache Software Foundation hat ihr Webseitendesign überarbeitet und sich ein neues Logo gegeben. Die Organisation sieht sich mit über 350...