Anmeldung an Gnome bricht ab

Dieses Thema im Forum "Gnome" wurde erstellt von Stollentroll, 05.05.2006.

  1. #1 Stollentroll, 05.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Hallo, ich habe folgendes Problem:
    Nachdem ich mich bei Gnome auf dem Startbildschirm angemeldet habe, erscheint das "Ladefenster" (korrigiert mich bitte, wie heißt das Ding?), und sobald es fertig geladen hat und eigentlich der Desktop erscheinen sollte, wird der Bildschirm schwarz und nach 2 Sekunden bin ich wieder auf der Anmeldeseite.
    Ich kann deshalb im Moment von der Anmeldeseite aus nur eine Konsolensitzung starten.

    Ich habe, als ich Gnome noch richtig starten konnte, unter System --> Einstellungen --> Tastatur die Tastatur in eine Logitech Tastatur geändert, von der ich gedacht hatte, dass sie meiner ähnlich ist und funktioniert. Da ich sonst nichts verstellt habe, vermute ich dass das den Fehler ausgelöst hat. Nun meine Frage:
    Wie kann ich von der Konsole aus diese Einstellung wieder rückgängig machen?

    Stollentroll

    Achso, ich benutze im Moment Debian Etch
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 DennisM, 05.05.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Guck mal in ~/.xsession-errors.

    MFG

    Dennis
     
  4. #3 Stollentroll, 05.05.2006
    Zuletzt bearbeitet: 05.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Das ist meine .xsession-errors

    Code:
    /etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
    /etc/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "christoph"
    /etc/gdm/Xsession: Beginning session setup...
    SESSION_MANAGER=local/RECHNER1:/tmp/.ICE-unix/6636
    The application 'gnome-session' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed the application.
    Nachdem ich 4-5 mal gnome gestartet --> Konsole gestartet habe und diese meldung 3 mal in der datei stand, wird es wohl die richtige sein.
    Wenn ich das richtig interpretiere wird der Xserver beendet, weswegen gnome dann den Zugriff auf den Bildschirm verliert und alles neu startet.
    Heißt dass, das ich den Übeltäter (die falsch eingestellte Tastatur) in einer "X Datei" finde?
    In Xorg.conf habe ich schon geschaut, der Eintrag zur Tastatur hat sich darin nicht verändert.
     
  5. #4 tuxlover, 05.05.2006
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    ja die müsste eigentlich in der xorg.conf zu finden sein. was für eine distri verwendest du?
     
  6. #5 Stollentroll, 05.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Ich verwende Debian Etch.

    In der xorg.conf steht unter Section "Input Device":
    Code:
    Identifier "Generic Keyboard"
    Driver     "keyboard"
    Option     "CoreKeyboard"
    Option     "XkbRules"     "xorg"
    Option     "XkbModel"     "pc105"
    Option     "XkbLayout"    "de"
    Option     "XkbVariant"   "nodeadkeys"
    Ich meine, dass dieser Abschnitt vor der Tastaturverstellerei genauso aussah, sicher bin ich mir aber nicht.
     
  7. #6 tuxlover, 05.05.2006
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    woher bist du dir so sicher dass es an der tastatur liegt hast du erst mal andere window-systeme probiert. vielleicht liegts auch einfach an gnome. du hast ja selber gesagt, dass die von dir verwendetet version unstable ist.
     
  8. #7 Stollentroll, 05.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Ich bin mir nicht sicher, dass es an der Tastatur liegt, aber mMn sprechen alle Indizien dafür.
    Ich habe an den Tastatureinstellungen rumgespielt, und beim nächsten Booten war das Problem da.
    Das ganze ist mir so ähnlich schon einmal passiert, nur dass ich noch nichts weiter konfiguriert hatte und der Einfachheit halber Debian neu aufgespielt habe.

    Wenn ich das richtig verstanden habe ist Etch im testing - Stadium, ich dachte da treten keine großen Fehler mehr auf.

    Wie kann ich denn rausfinden ob Gnome daran schuld ist, bzw wie heißt die entsprechende log Datei?
    Oder steht, abgesehen davon dass der X server sich verabschiedet hat und Gnome gleich mit noch ne andere relevante Fehlermeldung in der .xsession-errors?
    Für mich sehen die restlichen Einträge in der Datei nämlich eher nach einem normalen Startvorgang aus, aber ich bin in der Hinsicht auch ein ziemliches Greenhorn.
     
  9. #8 tuxlover, 05.05.2006
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    nein. wo hast du das denn eingstellt. in der konsole oder hast du eine gui unter gnome benutzt
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 Stollentroll, 05.05.2006
    Zuletzt bearbeitet: 05.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Ich hab in einer GUI unter Gnome den Tastaturtyp von der Standard-Einstellung auf eine Logitech Tastatur umgeschaltet, in der Hoffnung, dass meine Tastatur der Eingestellten ähnlich ist.
    Das Ganze war zu finden unter System --> Einstellungen --> Tastatur

    EDIT:
    Ich habe mir gerade eben KDE base installiert, und siehe da, damit klappt es. Allerdings wurde ich bei der Installation gefragt, welchen Window-Manager ich nutzen will, und da habe ich kdm angegeben.
    Ich gehe mal davon aus, dass Gnome standardmäßig den gdm nutzt.
    Ich schlussfolgere: entweder an Gnome ist etwas beschädigt, oder am gdm, und der Fehler, der mit gdm zusammenhängt, würde den X server zum Absturz bringen.
    Und das ist ja möglicherweise geschehen. (Die Meldung in der log bietet ja zwei Möglichkeiten an)

    Hab ich richtig gedacht?
     
  12. #10 Heinzelotto, 06.05.2006
    Heinzelotto

    Heinzelotto Grünschnabel

    Dabei seit:
    05.03.2006
    Beiträge:
    3
    Zustimmungen:
    0
    unter suse gibt es einen sogenannten abgesicherten modus. wenn du in diesem gestartet hast, hast du einen kasten mit eingabeaufforderung vor dir. In diese gibst du nun gnome ein, wodurch gnome gestartet wird. da kannst du dann in dem Kasten sehen, was vor sich geht und an welchem Punkt Gnome abstürzt. Unter Debian sollte es eigentlich auch so eine Funktion geben.
     
Thema:

Anmeldung an Gnome bricht ab

Die Seite wird geladen...

Anmeldung an Gnome bricht ab - Ähnliche Themen

  1. Anmeldung auf Samba4 Server

    Anmeldung auf Samba4 Server: Ein debian 8 server mit samba4 als pdc und file server installiert. Alle Konfigurationen sind gut gelaufen und samba4 hat bis jetzt einwandfrei...
  2. Anmeldung für LUG-Camp 2016 läuft

    Anmeldung für LUG-Camp 2016 läuft: Vom Donnerstag, den 5. Mai, bis zum Sonntag, den 8. Mai 2016, findet im badischen Bruchsal das mittlerweile 17. Treffen der Linux User Groups aus...
  3. Alias nach Ab- und Neuanmeldung futsch

    Alias nach Ab- und Neuanmeldung futsch: Ich habe in der .profile einen "alias" hinterlegt (alias='ordnera/ordnerb/ordnerc'). Wenn ich ab- und wieder anmelde, ist der "alias"...
  4. Anmeldung für Software Freedom Day 2014 gestartet

    Anmeldung für Software Freedom Day 2014 gestartet: Am Samstag, dem 20. September 2014, feiern Unterstützer freier Software in aller Welt wie in jedem Jahr den Software Freedom Day. Die...
  5. Anmeldung für Document Freedom Day 2014 gestartet

    Anmeldung für Document Freedom Day 2014 gestartet: Die Registrierungsphase für den Document Freedom Day 2014 hat begonnen. Der Document Freedom Day (DFD) findet immer am letzten Mittwoch im März...