Analoge "S-VHS" Videos digital archivieren

Dieses Thema im Forum "Grafik / Video" wurde erstellt von gtuser, 24.07.2007.

  1. #1 gtuser, 24.07.2007
    Zuletzt bearbeitet: 04.08.2007
    gtuser

    gtuser Eroberer

    Dabei seit:
    20.12.2006
    Beiträge:
    59
    Zustimmungen:
    0
    Ort:
    München
    Suche zusätzliche Tipps, um eine qualitativ hochwertige digitale Bearbeitung meiner S-VHS(C) Filmkasetten zu ermöglichen.

    Hard / Software:
    ------------------
    Linux gentoo01 2.6
    i686 AMD Athlon(tm) XP 2600+ AuthenticAMD GNU/Linux

    Soundkarte: Soundblaster live
    DVBT - Video Karte: Hauppauge WinTV-HVR-1300

    Momentaner Stand meiner Bemühungen:
    Erhalte eine sehr gute Video-Aufnahme mit dem Programm "mencoder".
    Habe verschiedene Parametern mit unterschiedlichen Ergebnissen probiert.
    Das Problem ist nicht die Qualität der Videoaufnahme (unter Linux), sondern der Ton.

    Wenn ich den Ton zusammen mit dem Videosignal in guter Qualität (25 fps und 720x576) von der HVR-1300 (cx88 Treiber) aufnehme, erhalte ich ständig "doppelte frames".
    Beim Abspielen läuft die Aufnahme dann mit verminderter Geschwindigkeit, der Ton auch. (Die Ton Frequenz ist dann viel zu tief)
    Wenn ich den Ton nicht dazunehme, erhalte ich ein sauberes Bild.

    Bild und Ton zusammen erhalte ich nur, wenn ich den Ton direkt von der Videokarte aufnehme.
    Bild in verminderter Qualität, aber Ton ist dann extrem verzerrt.

    Wenn ich den Ton versuche von der SBLive - Karte, die meine "default" - Karte ist, aufzunehmen (Der Ton von der Kamera wird dann auf Line-IN der SBlive umgestöpselt), höre ich zwar den Ton unverzerrt, aber bekomme keine Aufnahme zustande. Verwende ALSA Soundsystem, Kernelinterne Treiber unter Gentoo.

    Die alsamixer Einstellungen sind alle schon durchprobiert. (Playback und capture)
    An den Einstellungen scheint es nicht zu liegen.

    Wenn ich ein zweites Linux boote (Multiboot System), wo die Hauppauge WinTV HVR-1300 nicht installiert ist (auch keine DVB TV Module), dann kann ich von LINE-IN mit "arecord" einwandfrei in 16Bit Stereo mit 48kHz aufnehmen.
    (Bei gleichen Mixer Einstellungen wie gehabt)

    Wenn ich Windows-XP boote und die Aufnahme mit dem Programm MAGIX Studio versuche, kann ich den S-VSH Eingang nicht aktivieren. Kein Bild.

    Unter Windows erhalte ich nur eine Aufnahme mit der Original Hauppauge Software, allerdings ist mein Rechner dann zu langsam, oder hat zu wenig Arbeitsspeicher für die volle Auflösung. Kann dann nur in verminderter Qualität aufnehmen. Der Ressourcenverbrauch ist ansscheinend zu hoch.
    Gefordert sind mindestens 1Gbyte Arbeitsspeicher, habe aber momentan nur 512Mb drin.

    Die DVBT = Fernsehfunktion funktioniert mittlerweile unter beiden Betriebssystemen ungefähr gleich gut.
    Unter Linux ist die Umschaltung zwischen den Programmen bei mir etwas fixer, aber die Empfindlichkeit (subjektiv) minimal schlechter.
    Wird wohl davon abhängen, was alles so im Hintergrund läuft.

    Es sieht für mich so aus, dass die SBlive einen Konflikt mit der Hauppauge TV Karte hat.

    Kann mir jemand zum Thema Sound SBlive mit DVBT-Karte Tipps geben?
    Der fehlende Ton bei aktivierter zweiter Soundkarte beschäftigt mich schon seit Tagen.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 gtuser, 04.08.2007
    Zuletzt bearbeitet: 04.08.2007
    gtuser

    gtuser Eroberer

    Dabei seit:
    20.12.2006
    Beiträge:
    59
    Zustimmungen:
    0
    Ort:
    München
    Da keine Hinweise eingegangen sind, und der SoundKonflikt mit den beiden Karten weiterhin besteht, habe ich mir unter Windows-XP das Programm "Virtual Dub" installiert.
    Damit kann ich alle Filme ohne Probleme in guter Qualität aber reduzierte Fram Grösse (384 x 288, 24Bit RGB) und mit Ton aufzeichnen.

    Höhere Bildgrössen funktionieren auch mit Virtual Dub bei mir bis jetzt nicht.
    Werde noch mal unter Linux mit geringerer Bildgrösse als 720x576 experimentieren.
    Allerdings is da immer noch dasProblem mit dem verzerrten Sound und keine Aufnahme von der SBlive möglich.

    Für diese Aufgabe werde ich also Windows hernehmen. Habe sowieso ein Dualboot System.
     
  4. b00

    b00 Haudegen

    Dabei seit:
    28.03.2007
    Beiträge:
    597
    Zustimmungen:
    0
    Ort:
    /root
    poste bitte die mencoder befehlszeile
    und
    Code:
    aplay -lL
    cat /proc/asound/cards
    
     
  5. gtuser

    gtuser Eroberer

    Dabei seit:
    20.12.2006
    Beiträge:
    59
    Zustimmungen:
    0
    Ort:
    München
    HAbe verschieden Einstellungen probiert.

    Mit streamer

    Das funzt mit cx88 Karte:

    arecord -D hw:1,0 -c 2 -r 48000 -f S16_LE -t wav | aplay - &
    streamer -i S-Video -t 45:00 -b 64 -n PAL-BG -j 85 -r 25 -F stereo -o aufnahme.avi

    und mencoder
    mencoder -tv driver=v4l2:input=2:width=720:height=576 -o aufnahme.avi -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=6000:ilme:ildct:acodec=mp2:abitrate=224 -oac mp3lame tv://


    aplay -lL
    front:CARD=Live,DEV=0
    SB Live [Unknown], ADC Capture/Standard PCM Playback
    Front speakers
    rear:CARD=Live,DEV=0
    SB Live [Unknown], ADC Capture/Standard PCM Playback
    Rear speakers
    center_lfe:CARD=Live,DEV=0
    SB Live [Unknown], ADC Capture/Standard PCM Playback
    Center and Subwoofer speakers
    surround40:CARD=Live,DEV=0
    SB Live [Unknown], ADC Capture/Standard PCM Playback
    4.0 Surround output to Front and Rear speakers
    surround41:CARD=Live,DEV=0
    SB Live [Unknown], ADC Capture/Standard PCM Playback
    4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=Live,DEV=0
    SB Live [Unknown], ADC Capture/Standard PCM Playback
    5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=Live,DEV=0
    SB Live [Unknown], ADC Capture/Standard PCM Playback
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    iec958:CARD=Live,DEV=0
    SB Live [Unknown], Multichannel Capture/PT Playback
    IEC958 (S/PDIF) Digital Audio Output
    null
    Discard all samples (playback) or generate zero samples (capture)
    **** List of PLAYBACK Hardware Devices ****
    card 0: Live [SB Live [Unknown]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
    Subdevices: 32/32
    Subdevice #0: subdevice #0
    Subdevice #1: subdevice #1
    Subdevice #2: subdevice #2
    Subdevice #3: subdevice #3
    Subdevice #4: subdevice #4
    Subdevice #5: subdevice #5
    Subdevice #6: subdevice #6
    Subdevice #7: subdevice #7
    Subdevice #8: subdevice #8
    Subdevice #9: subdevice #9
    Subdevice #10: subdevice #10
    Subdevice #11: subdevice #11
    Subdevice #12: subdevice #12
    Subdevice #13: subdevice #13
    Subdevice #14: subdevice #14
    Subdevice #15: subdevice #15
    Subdevice #16: subdevice #16
    Subdevice #17: subdevice #17
    Subdevice #18: subdevice #18
    Subdevice #19: subdevice #19
    Subdevice #20: subdevice #20
    Subdevice #21: subdevice #21
    Subdevice #22: subdevice #22
    Subdevice #23: subdevice #23
    Subdevice #24: subdevice #24
    Subdevice #25: subdevice #25
    Subdevice #26: subdevice #26
    Subdevice #27: subdevice #27
    Subdevice #28: subdevice #28
    Subdevice #29: subdevice #29
    Subdevice #30: subdevice #30
    Subdevice #31: subdevice #31
    card 0: Live [SB Live [Unknown]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
    Subdevices: 8/8
    Subdevice #0: subdevice #0
    Subdevice #1: subdevice #1
    Subdevice #2: subdevice #2
    Subdevice #3: subdevice #3
    Subdevice #4: subdevice #4
    Subdevice #5: subdevice #5
    Subdevice #6: subdevice #6
    Subdevice #7: subdevice #7
    card 0: Live [SB Live [Unknown]], device 3: emu10k1 [Multichannel Playback]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    ---------------------------------------
    Aha sehe ein Unknown device ???
     
  6. b00

    b00 Haudegen

    Dabei seit:
    28.03.2007
    Beiträge:
    597
    Zustimmungen:
    0
    Ort:
    /root
    ja ob das dass problem ist? (neuste alsa mal checken)

    probiere bitte mit mencoder OHNE komprimierung von audio auf zu nehmen, um den fehler ein zu kreisen.

    evtl. wenn es dir möglich ist ein kurzes freies testfile zu uppen?
     
  7. #6 gtuser, 07.08.2007
    Zuletzt bearbeitet: 07.08.2007
    gtuser

    gtuser Eroberer

    Dabei seit:
    20.12.2006
    Beiträge:
    59
    Zustimmungen:
    0
    Ort:
    München
    Mein einziges Problem ist momentan, dass ich beim sound "capture" d.h. Aufnahme vom "cx88-alsa" Gerät (Hauppauge) einen stark verzerrten Ton bekomme und bei der Aufnahme von der Creative SBlive gar nichts, wenn beide Karten aktiviert sind.
    Wenn nur das Modul für die SBlive geladen ist, habe ich einen einwandfreien Ton, allerdings natürlich keine Videofunktion.

    Hatte gerade noch eine Unterstützung an anderer Stelle in diesem Forum zu einem ähnlichen Thema am laufen.

    "Driver für Creative SB Live! 24-Bit"
    Das war auch ein Problem mit einer zweiten Sound-Karte.

    Da bin ich dann drauf gekommen, mal nach "patches" zu sehen.

    Und siehe da, das Problem ist schon bekannt.

    [PATCH 04/16] VIDEO_CX88_ALSA must select SND_PCM
    http://linux.derkeiler.com/Mailing-Lists/Kernel/2006-01/msg08901.html

    Ich denke, da liegt der Hund begraben.

    Mehr eventuell später, falls ich was herausbekomme.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Analoge "S-VHS" Videos digital archivieren

Die Seite wird geladen...

Analoge "S-VHS" Videos digital archivieren - Ähnliche Themen

  1. (Analoge) Schaltungssimulation

    (Analoge) Schaltungssimulation: Hi @ all Wie es der Titel schon sagt ,suche ich nach einer Anwendung um Schaltungen zu simulieren. Hab bereits danach im Google gesucht und was...
  2. Suche analogen Shell Befehl zu

    Suche analogen Shell Befehl zu: Hi gibt es einen befehl der den selben zweck erfüllt wie in perl $string =~ /([abc])/ print $1; also aus einem string den wert eines...
  3. analoge TV-Karte(Medion) unter Debian

    analoge TV-Karte(Medion) unter Debian: analoge TV-Karte > Neues Problem Hallo, hab jetzt im Moment mal wieder etwas mehr Zeit und wollte deshalb mal wieder etwas experimentieren ;)...
  4. Kaffeine Analogesenderliste

    Kaffeine Analogesenderliste: Hallo Leute, habe Kaffeine installiert um damit zu Fehrsehen, das ja wunderbar geht, leider nur Digitale Sender wo bekommt man die Senderliste...
  5. Welches analoge Modem?

    Welches analoge Modem?: Hallo, bin neu hier und sage erst mal artig Guten Tag. Ich benutze seit längerer Zeit SuSE Linux, aktuell die Version 10.2 ohne tiefgreifende...