Alsa: snd-hda-intel geht nicht mehr

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Hermodur, 25.08.2011.

  1. #1 Hermodur, 25.08.2011
    Hermodur

    Hermodur Grünschnabel

    Dabei seit:
    17.01.2007
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo,

    ich verwende Aptosid als Distribution und hatte bisher keine nennenswerten Probleme mit ALSA. Ich habe eine interne Soundkarte, die ich bisher mit "modprobe snd-hda-intel model=3stack" prima einbinden konnte (das ganze natürlich per /etc/modprobe.d/alsa-base.conf und passiert normalerweise automatisch).
    Seit dem Wechsel auf die 3-er-Kernelserie habe ich nun keinen Sound mehr. Nachschauen in /var/log/messages bringt folgendes zutage:
    Code:
    modprobe snd-hda-intel model=3stack
    HDA Intel: probe of 0000:00:1b.0 failed with error -16
    
    - Die Harware ist okay, da ich mit OSS4 guten Sound habe (aber leider nicht in allen Anwendungen).
    - Das Paket alsa-base habe ich bereits mehrmals neu installiert.
    - Ein "cat bla.wav > /dev/audio" erzeugt die Fehlermeldung "/dev/dsp: Das Argument ist ungültig", gleiches gilt für /dev/dsp.
    - Der Audio-Eingang meiner TV-Karte wird problemlos erkannt.

    Hat jemand eine Idee, was ich falsch mache?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 25.08.2011
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Evtl. sind mehrere Codecs für HDA-Intel im Kernel aktiviert, die untereinander Konflikte verursachen. Evtl. hat das System aber auch fälschlicherweise einfach noch einen anderen Soundtreiber geladen. Wenn beides nicht der Fall ist, wirst du vermutlich nur näheres erfahren, wenn du Sound-Debugging und Kernel aktivierst (CONFIG_SND_DEBUG + CONFIG_SND_DEBUG_DETECT beim Kompilieren des Kernels aktivieren). Gibst evtl. in der Ausgabe von dmesg mehr Meldungen als die, die dir modprobe direkt auswirft? Was findet sich zu 'hda_codec' im Kernel-Log (üblicherweise /var/log/messages)?
     
Thema:

Alsa: snd-hda-intel geht nicht mehr

Die Seite wird geladen...

Alsa: snd-hda-intel geht nicht mehr - Ähnliche Themen

  1. Asus U30sd + Arch + Alsa...

    Asus U30sd + Arch + Alsa...: Moin, ich habe hier ein Asus U30SD mit Arch aufgesetzt, was auch recht gut läuft. Nun allerdings hab ich so meine Schwierigkeiten mit Alsa und...
  2. »OpenSuse Box« wird zu »Balsam Professional«

    »OpenSuse Box« wird zu »Balsam Professional«: Die open-slx GmbH, bekannt als Anbieter der »OpenSuse Box« und des OpenSuse-Anwender-Supports, kündigte mit »Balsam Professional« ein auf...
  3. VLC redundantes Einstellungs-hin-und-her-aendern [ALSA]

    VLC redundantes Einstellungs-hin-und-her-aendern [ALSA]: Hier mal wieder ein Problem: Da ich ueber das optische SPDIF zum Verstaerker gehe, habe ich bei den VLC Einstellungen unter Sound als Output...
  4. alsaconf ja oder nein

    alsaconf ja oder nein: Hallo Was haltet ihr davon, daß alsaconf bei einigen Distrsi (Debian, Ubuntu) nicht mehr in den Alsa-utils auftaucht. Ich finde es sehr...
  5. alsaconf ist verschwunden

    alsaconf ist verschwunden: Hi @ALL, irgendwie nach meinem letzten automatischen Systemupdate ist die glx-unterstützung für meine geforce verschwunde, konnte sie aber...