[ALSA] Problem

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von commx, 09.05.2005.

  1. commx

    commx GamerIRC-Staff

    Dabei seit:
    09.05.2005
    Beiträge:
    12
    Zustimmungen:
    0
    Ort:
    Spremberg
    Hallo erstmal!

    Ich hab da eine Audigy LS von Creative, einige von euch wissen sicher dass die Karte nich umbedingt für Linux geeignet ist, aber ich möchte sie gerne nutzen, denn das AC97 onBoard dings entspricht nicht umbedingt meinen Anforderungen.

    Nun läuft diese Karte nur mit dem sogenannten 'ca0106' treiber von ALSA. Also hab ich alsa-driver, alsa-lib, alsa-utils (alle version 1.0.8) installiert. Soweit so gut.
    Mit alsaconf noch schnell die Karte eingestellt, funktionierte wunderbar und dann noch ne Datei /etc/modutils/alsa angelegt und folgendes reingeschrieben und gespeichert:

    Code:
    # ALSA portion
    alias char-major-116 snd
    alias snd-card-0 snd-ca0106
    # module options should go here
    
    # OSS/Free portion
    alias char-major-14 soundcore
    alias sound-slot-0 snd-card-0
    
    # card #1
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss
    
    Nun will ich per KDE-Kontrollzentrum den Sound-Server (artsd) auf ALSA umschalten, und da gibts schon das erste Problem:
    (Fehlermeldung): Error while initializing the sound driver:
    device: default can't be opened for Playback (Permission denied)

    Nun hab ich gestern Nacht irgendwie rumgefuchtelt und diesen Fehler weggekriegt, allerdings hab ich den jetzt wieder (nachdem ich nochmal alsaconf gemacht hab) und ich weiss nich mehr wie das ging. Jedenfalls lief die Audigy gestern - aber wie...

    Der Sound wurde viel zu schnell abgespielt, mindestens doppelt so schnell wie normal und dabei hats auch noch gekratzt... furchtbar!
    In XMMS hab ich versucht auch abzuspielen, da geht gar nix:
    - Mit OSS Plugin kommt kein Sound, läuft aber
    - Mit ALSA Plugin kommt ein Fehler, dass die Karte bereits benutzt wird.

    Nochmal ein paar Informationen:

    (DMESG)
    Code:
    Via 686a/8233/8235 audio driver 1.9.1-ac4-2.5
    ACPI: PCI interrupt 0000:00:07.5[C] -> GSI 12 (level, low) -> IRQ 12
    PCI: Setting latency timer of device 0000:00:07.5 to 64
    ac97_codec: AC97 Audio codec, id: ICE17 (ICE1232)
    via82cxxx: board #1 at 0xCC00, IRQ 12
    Enabled Via MIDI
    NET: Registered protocol family 2
    IP: routing cache hash table of 2048 buckets, 16Kbytes
    TCP: Hash tables configured (established 16384 bind 32768)
    NET: Registered protocol family 8
    NET: Registered protocol family 20
    ACPI: (supports S0 S1 S4 S5)
    RAMDISK: cramfs filesystem found at block 0
    RAMDISK: Loading 3780 blocks [1 disk] into ram disk... done.
    VFS: Mounted root (cramfs filesystem) readonly.
    Freeing unused kernel memory: 232k freed
    NET: Registered protocol family 1
    SCSI subsystem initialized
    Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    usb 2-1: new low speed USB device using address 2
    VP_IDE: IDE controller at PCI slot 0000:00:07.1
    VP_IDE: chipset revision 6
    VP_IDE: not 100% native mode: will probe irqs later
    VP_IDE: VIA vt82c686b (rev 40) IDE UDMA100 controller on pci0000:00:07.1
        ide0: BM-DMA at 0xc000-0xc007, BIOS settings: hda:DMA, hdb:pio
        ide1: BM-DMA at 0xc008-0xc00f, BIOS settings: hdc:DMA, hdd:DMA
    usb 2-2: new full speed USB device using address 3
    hda: ST340823A, ATA DISK drive
    Using anticipatory io scheduler
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    hda: max request size: 128KiB
    hda: 78165360 sectors (40020 MB) w/1024KiB Cache, CHS=65535/16/63, UDMA(100)
     /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 < p5 p6 >
    hdc: AOPEN CD-RW CRW5224 1.05 20021212, ATAPI CD/DVD-ROM drive
    hdd: SAMSUNG DVD-ROM SD-612S, ATAPI CD/DVD-ROM drive
    ide1 at 0x170-0x177,0x376 on irq 15
    kjournald starting.  Commit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    Adding 2208896k swap on /dev/hda6.  Priority:-1 extents:1
    EXT3 FS on hda5, internal journal
    hdc: ATAPI 52X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
    Uniform CD-ROM driver Revision: 3.20
    hdd: ATAPI 40X DVD-ROM drive, 512kB Cache, UDMA(33)
    Linux agpgart interface v0.100 (c) Dave Jones
    parport_pc: VIA 686A/8231 detected
    parport_pc: probing current configuration
    parport_pc: Current parallel port base: 0x378
    parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,EPP]
    parport_pc: VIA parallel port: io=0x378, irq=7
    agpgart: Detected VIA Apollo Pro 133 chipset
    agpgart: Maximum main memory to use for agp memory: 203M
    agpgart: AGP aperture is 32M @ 0xe2000000
    pci_hotplug: PCI Hot Plug PCI Core version: 0.5
    pciehp: acpi_pciehprm:\_SB_.PCI0 evaluate _BBN fail=0x5
    pciehp: acpi_pciehprm:get_device PCI ROOT HID fail=0x5
    shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
    shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
    ACPI: PCI interrupt 0000:00:10.0[A] -> GSI 12 (level, low) -> IRQ 12
    Model 1002 Rev 00000000 Serial 10021102
    ALSA /usr/src/alsa-driver-1.0.8/acore/oss/pcm_oss.c:2436: unable to register OSS PCM device 0:0
    ALSA /usr/src/alsa-driver-1.0.8/acore/oss/mixer_oss.c:1260: unable to register OSS mixer device 0:0
    usbcore: registered new driver hiddev
    input: USB HID v1.10 Mouse [Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)] on usb-0000:00:07.3-1
    usbcore: registered new driver usbhid
    drivers/usb/input/hid-core.c: v2.0:USB HID core driver
    drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 3 if 0 alt 1 proto 2 vid 0x03F0 pid 0x0C17
    usbcore: registered new driver usblp
    drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
    inserting floppy driver for 2.6.8
    Floppy drive(s): fd0 is 1.44M
    FDC 0 is a post-1991 82077
    Serial: 8250/16550 driver $Revision: 1.90 $ 14 ports, IRQ sharing disabled
    ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
    pnp: the driver 'serial' has been registered
    pnp: match found with the PnP device '00:0d' and the driver 'serial'
    pnp: match found with the PnP device '00:0e' and the driver 'serial'
    eth0: link up, 10Mbps, half-duplex, lpa 0x0000
    lp0: using parport0 (interrupt-driven).
    NET: Registered protocol family 10
    Disabled Privacy Extensions on device c0359f80(lo)
    IPv6 over IPv4 tunneling driver
    eth0: no IPv6 routers present
    ip_tables: (C) 2000-2002 Netfilter core team
    ip_conntrack version 2.1 (2047 buckets, 16376 max) - 296 bytes per conntrack
    ALSA /usr/src/alsa-driver-1.0.8/acore/seq/oss/seq_oss.c:236: can't register device seq
    ALSA /usr/src/alsa-driver-1.0.8/acore/seq/oss/seq_oss.c:236: can't register device seq
    ALSA /usr/src/alsa-driver-1.0.8/acore/seq/oss/seq_oss.c:236: can't register device seq
    ALSA /usr/src/alsa-driver-1.0.8/acore/seq/oss/seq_oss.c:236: can't register device seq
    ALSA /usr/src/alsa-driver-1.0.8/acore/seq/oss/seq_oss.c:236: can't register device seq
    ALSA /usr/src/alsa-driver-1.0.8/acore/seq/oss/seq_oss.c:236: can't register device seq
    ALSA /usr/src/alsa-driver-1.0.8/acore/seq/oss/seq_oss.c:236: can't register device seq
    ALSA /usr/src/alsa-driver-1.0.8/acore/seq/oss/seq_oss.c:236: can't register device seq
    ALSA /usr/src/alsa-driver-1.0.8/acore/seq/oss/seq_oss.c:236: can't register device seq
    ALSA /usr/src/alsa-driver-1.0.8/acore/seq/oss/seq_oss.c:236: can't register device seq
    ACPI: PCI interrupt 0000:00:10.0[A] -> GSI 12 (level, low) -> IRQ 12
    Model 1002 Rev 00000000 Serial 10021102
    ALSA /usr/src/alsa-driver-1.0.8/acore/oss/pcm_oss.c:2436: unable to register OSS PCM device 0:0
    ALSA /usr/src/alsa-driver-1.0.8/acore/oss/mixer_oss.c:1260: unable to register OSS mixer device 0:0
    via_audio: ignoring drain playback error -11
    via_audio: ignoring drain playback error -11
    via_audio: ignoring drain playback error -11
    via_audio: ignoring drain playback error -11
    via_audio: ignoring drain playback error -11
    via_audio: ignoring drain playback error -11
    via_audio: ignoring drain playback error -11
    via_audio: ignoring drain playback error -11
    via_audio: ignoring drain playback error -11
    via_audio: ignoring drain playback error -11
    via_audio: ignoring drain playback error -11
    
    (LSPCI)
    Code:
    0000:00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev c4)
    0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
    0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
    0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
    0000:00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
    0000:00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
    0000:00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
    0000:00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
    0000:00:0f.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    0000:00:10.0 Multimedia audio controller: Creative Labs SB Audigy LS
    0000:00:10.1 Input device controller: Creative Labs SB Audigy LS MIDI/Game port
    0000:01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev a1)
    
    (LSMOD)
    Code:
    Module                  Size  Used by
    snd_ca0106             30416  0
    snd_ac97_codec         78616  1 snd_ca0106
    snd_pcm_oss            53128  0
    snd_mixer_oss          19840  1 snd_pcm_oss
    snd_pcm                92808  3 snd_ca0106,snd_ac97_codec,snd_pcm_oss
    snd_timer              24740  1 snd_pcm
    snd                    57732  6 snd_ca0106,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
    ipt_state               2080  2
    iptable_filter          2880  1
    iptable_mangle          2880  0
    iptable_nat            24716  0
    ip_conntrack           34700  2 ipt_state,iptable_nat
    ip_tables              17344  4 ipt_state,iptable_filter,iptable_mangle,iptable_nat
    md5                     4000  1
    ipv6                  255012  10
    lp                     11176  0
    8250_pnp                8384  0
    8250                   22816  1 8250_pnp
    serial_core            22464  1 8250
    floppy                 59216  0
    usblp                  12864  0
    joydev                  9984  0
    evdev                   9600  0
    usbhid                 32000  0
    snd_page_alloc         10120  2 snd_ca0106,snd_pcm
    pci_hotplug            11268  0
    via_agp                 9056  1
    parport_pc             36516  1
    parport                40776  2 lp,parport_pc
    agpgart                34344  1 via_agp
    cpuid                   3044  0
    ide_cd                 42080  0
    cdrom                  40508  1 ide_cd
    ext3                  124520  1
    jbd                    57912  1 ext3
    ide_generic             1408  0
    via82cxxx              14140  1
    ide_disk               20992  3
    ide_core              133240  4 ide_cd,ide_generic,via82cxxx,ide_disk
    sd_mod                 20160  0
    scsi_mod              123212  1 sd_mod
    unix                   27156  385
    
    Zur Information: Ich nutze Aktuell die VIA AC97 onBoard, deswegen via_audio im dmesg.

    Ich hoffe ihr könnt mir da weiterhelfen, verzweifel schon langsam.
    Danke im Vorraus!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

[ALSA] Problem

Die Seite wird geladen...

[ALSA] Problem - Ähnliche Themen

  1. VLC redundantes Einstellungs-hin-und-her-aendern [ALSA]

    VLC redundantes Einstellungs-hin-und-her-aendern [ALSA]: Hier mal wieder ein Problem: Da ich ueber das optische SPDIF zum Verstaerker gehe, habe ich bei den VLC Einstellungen unter Sound als Output...
  2. [ALSA] Patch: ac97_codec ALC655: add EAPD hack for MSI L725

    [ALSA] Patch: ac97_codec ALC655: add EAPD hack for MSI L725: Hallo ! Im System wird die Saundkarte richtig erkannt aber der sound kommt nur auf line out, die AC97 Quirk Option hab ich auch ohne erfolg...
  3. Virtualboxproblem

    Virtualboxproblem: Hallo Folgnedes Problem: Ich kann ohne Probleme In Debian-Sid, 64Bit und virtualbox-dkms Unixoide installieren, wenn es sich um eine...
  4. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  5. Problem bei apt-get upgrade (Kali 2.0)

    Problem bei apt-get upgrade (Kali 2.0): Hi, seit paar Tagen habe ich einige Probs. Dachte es sei mal an der Zeit für ein Update und nun tauchen da einige Fehler auf: Es müssen noch 0 B...