ALSA Hardware zuweisen

Dieses Thema im Forum "Sound" wurde erstellt von BigButcher, 17.04.2005.

  1. #1 BigButcher, 17.04.2005
    BigButcher

    BigButcher Jungspund

    Dabei seit:
    19.01.2005
    Beiträge:
    23
    Zustimmungen:
    0
    Moin Moin,

    erstaunt hab ich heute festgestellt dass mein KUbuntu Hoary auf dem digitalen Ausgang meiner Soundkarte Signale aussenden kann.
    (ASUS A7N8X - Deluxe Mobo)
    Dies hab ich mit dem Befehl
    Code:
    aplay -D spdif /home/apostel/Desktop/chord.wav
    bzw:
    Code:
    aplay -D hw:0,2 /home/apostel/Desktop/chord.wav
    und Xmms in der ALSA Config herausgefunden, als da plötzlich sound aus den Boxen kam!
    Soo nu weiss ich ja, dass hw:0,2 für meinen digitalen Audioausgang zuständig ist, aber was muss ich machen, damit ALSA den als Default benutzt und somit alle Anwenungen die auf ALSA zurückgreifen, über den digitalen Ausgang "geroutet" werden?

    MfG

    BB
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Atomara, 17.04.2005
    Atomara

    Atomara Debrandeter User

    Dabei seit:
    06.03.2004
    Beiträge:
    1.255
    Zustimmungen:
    0
    Ort:
    Deutschland , Nrw , Münsterland
    für sowas gibt es eine .asoundrc ,wie die in deinem falle aussehen sollte kann ich dir leider nicht sagen
     
  4. #3 BigButcher, 18.04.2005
    BigButcher

    BigButcher Jungspund

    Dabei seit:
    19.01.2005
    Beiträge:
    23
    Zustimmungen:
    0
    So ich hab mal eine /home/XXX/.asoundrc erstellt mit folgendem Inhalt

    Code:
    pcm.intel8x0 {
            type hw
            card 0
            device 0
            subdevice 2
    }
    
    ctl.intel8x0 {
            type hw
            card 0
            device 0
            subdevice 2
    
    }
    Aber da tut sich noch nix spürbares.
    In meiner /proc/asound hab ich folgende Geräte

    - card0 <- Soundkarte
    - card1 <- TV Karte
    - nForce2 <-link auf card0
    - oss und seq

    Und muss ich die .asoundrc noch irgendwo in einer conf einbinden, oder so ähnlich? Weil die hab ich neu erstellt und davor gabs noch keine.

    MfG

    BB
     
  5. #4 BigButcher, 18.04.2005
    BigButcher

    BigButcher Jungspund

    Dabei seit:
    19.01.2005
    Beiträge:
    23
    Zustimmungen:
    0

    Anhänge:

    • alsa.jpg
      alsa.jpg
      Dateigröße:
      141,3 KB
      Aufrufe:
      25
  6. #5 BigButcher, 19.04.2005
    BigButcher

    BigButcher Jungspund

    Dabei seit:
    19.01.2005
    Beiträge:
    23
    Zustimmungen:
    0
    AAAlso

    ich hab es endlich geschafft, ich möchte euch meine Ergebnisse auch nicht vorenthalten!

    Das ist meine /etc/asound.conf
    Code:
    pcm.!default { 
    type hw 
    card 0 
    device 2 
    }
    
    # Override the default output used by ALSA.
    # If you do not override the default, your default
    # device is identical to the (unmixed) analog device
    # shown below.  If you prefer mixed and/or digital
    # output, uncomment the appropriate four lines below
    # (only one slave.pcm line).
    #pcm.!default {
    #  type plug
    ## Uncomment the following to use mixed analog by default
    #  slave.pcm "dmix-analog"
    ## Uncomment the following to use unmixed digital by default
    #  slave.pcm "digital-hw"
    ## Uncomment the following to use mixed digital by default
    #  slave.pcm "dmix-digital"
    #}
    
    # Alias for analog output on the nForce2/4 (hw:0,0)
    # - This is identical to the device named "default"--which
    # always exists and refers to hw:0,0 (unless overridden)
    # - Therefore, we can specify "hw:0,0", "default", or "analog"
    # to access analog output on the nForce2/4
    pcm.analog {
     type plug
     slave.pcm "analog-hw"
    }
    
    # Control device (mixer, etc.) for the nForce2 card
    ctl.analog {
     type hw
     card 0
    }
    
    # Alias for (rate-converted) mixed analog output on the
    # nForce2 (hw:0,0)
    #  - This will accept audio input--regardless of rate--and
    # convert to the rate required for the dmix plugin
    # (in this case 48000Hz)
    pcm.mixed-analog {
     type plug
     slave.pcm "dmix-analog"
    }
    
    # Control device (mixer, etc.) for the nForce2 card
    ctl.mixed-analog {
     type hw
     card 0
    }
    
    # Alias for (rate-converted) digital (S/PDIF) output on the
    # nForce2 (hw:0,2)
    #  - This will accept audio input--regardless of rate--and
    # convert to the rate required for the S/PDIF hardware
    # (in this case 48000Hz)
    pcm.digital {
     type plug
     slave.pcm "digital-hw"
    }
    
    # Control device (mixer, etc.) for the nForce2 card
    ctl.digital {
     type hw
     card 0
    }
    
    # Alias for mixed (rate-converted) digital (S/PDIF) output on the
    # nForce2/4 (hw:0,2)
    #  - This will accept audio input--regardless of rate--and
    # convert to the rate required for the S/PDIF hardware
    # (in this case 48000Hz)
    pcm.mixed-digital {
     type plug
     slave.pcm "dmix-digital"
    }
    
    # Control device (mixer, etc.) for the nForce2 card
    ctl.mixed-digital {
     type hw
     card 0
    }
    
    # The following devices are not useful by themselves.  They
    # require specific rates, channels, and formats.  Therefore,
    # you probably do not want to use them directly.  Instead use
    # of of the devices defined above.
    
    # Alias for analog output on the nForce2 (hw:0,0)
    # Do not use this directly--it requires specific rate,
    # channels, and format
    pcm.analog-hw {
     type hw
     card 0
     # The default value for device is 0, so no need to specify
    }
    
    # Control device (mixer, etc.) for the nForce2/4 card
    ctl.analog-hw {
     type hw
     card 0
    }
    
    # Alias for digital (S/PDIF) output on the nForce2/4 (hw:0,2)
    # Do not use this directly--it requires specific rate,
    # channels, and format
    pcm.digital-hw {
     type hw
     card 0
     device 2
    }
    
    # Control device (mixer, etc.) for the nForce2/4 card
    ctl.digital-hw {
     type hw
     card 0
    }
    
    # Direct software mixing plugin for analog output on
    # the nForce2/4 (hw:0,0)
    # Do not use this directly--it requires specific rate,
    # channels, and format
    pcm.dmix-analog {
     type dmix
     ipc_key 1234
     slave {
       pcm "analog-hw"
       period_time 0
       period_size 1024
       buffer_size 4096
       rate 48000
     }
    }
    
    # Control device (mixer, etc.) for the nForce2/4 card
    ctl.dmix-analog {
     type hw
     card 0
    }
    
    # Direct software mixing plugin for digital (S/PDIF) output
    # on the nForce2/4 (hw:0,2)
    # Do not use this directly--it requires specific rate,
    # channels, and format
    pcm.dmix-digital {
     type dmix
     ipc_key 1235
     slave {
       pcm "digital-hw"
       period_time 0
       period_size 1024
       buffer_size 4096
       rate 48000
     }
    }
    
    # Control device (mixer, etc.) for the nForce2/4 card
    ctl.dmix-digital {
     type hw
     card 0
    }
    
    Der Fehler auf dem Screenshot kam, weil ich die Soundkarte auf Vollduplex geschaltet hab, was natürlich Schwachsinn ist, weil das ja nur ein Audioausgang ist!

    Also nicht den gleichen Fehler machen :)

    MfG

    BB
     
  7. #6 regatus, 09.06.2005
    regatus

    regatus Grünschnabel

    Dabei seit:
    09.06.2005
    Beiträge:
    5
    Zustimmungen:
    0
    klappt wunderbar. jetzt hab ich noch eine frage:
    ich hab ne tv karte drin und bekomm den sound über den line-in. wie bekomme ich den auch auf den spdif ausgang? unter windows gabs in dem nvidia-sound-mixer ne option die sich "eingang digitalisieren" nannte.

    mfg
    regatus
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

ALSA Hardware zuweisen

Die Seite wird geladen...

ALSA Hardware zuweisen - Ähnliche Themen

  1. oss für surround konfigurieren, alsa blockiert hardware

    oss für surround konfigurieren, alsa blockiert hardware: Hi, ich benutze Debian testing und habe ein Soundproblem. Normalerweise benutze ich als musikspieler Amarok mit alsa. Damit der Stereosound auf...
  2. Asus U30sd + Arch + Alsa...

    Asus U30sd + Arch + Alsa...: Moin, ich habe hier ein Asus U30SD mit Arch aufgesetzt, was auch recht gut läuft. Nun allerdings hab ich so meine Schwierigkeiten mit Alsa und...
  3. Alsa: snd-hda-intel geht nicht mehr

    Alsa: snd-hda-intel geht nicht mehr: Hallo, ich verwende Aptosid als Distribution und hatte bisher keine nennenswerten Probleme mit ALSA. Ich habe eine interne Soundkarte, die ich...
  4. »OpenSuse Box« wird zu »Balsam Professional«

    »OpenSuse Box« wird zu »Balsam Professional«: Die open-slx GmbH, bekannt als Anbieter der »OpenSuse Box« und des OpenSuse-Anwender-Supports, kündigte mit »Balsam Professional« ein auf...
  5. VLC redundantes Einstellungs-hin-und-her-aendern [ALSA]

    VLC redundantes Einstellungs-hin-und-her-aendern [ALSA]: Hier mal wieder ein Problem: Da ich ueber das optische SPDIF zum Verstaerker gehe, habe ich bei den VLC Einstellungen unter Sound als Output...