Abruch von Java - Programm mit Fehlermeldung

Dieses Thema: "Abruch von Java - Programm mit Fehlermeldung" im Forum "Java/Mono/dotGNU" wurde erstellt von munuel, 12.01.2006.

  1. munuel

    munuel Eroberer

    Dabei seit:
    11.09.2004
    Beiträge:
    53
    Zustimmungen:
    0
    hallo,
    Ich hab ein Java - Programm, welches ich installieren will, bei der Installation tritt folgender Fehler auf!
    -----------------------------------------------------------------------------------------------------
    Exception in thread "main" java.lang.UnsupportedClassVersionError: conftest (Unsupported major.minor version 49.0)
    at java.lang.ClassLoader.defineClass0(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
    Exception in thread "main" java.lang.UnsupportedClassVersionError:

    Acquirement of Java home directory and Java vender name is failed.
    The program returned an error code (1)
    -------------------------------------------------------------------------------------------------------

    Verwende ich da die falsche Java Version ? Habe unter /usr/java/jdk1.5
    /usr/java/jre1.5
    liegen!

    Viele Grüsse munuel
     
  2. Anzeige

    schau mal hier --> (hier klicken). Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 DennisM, 12.01.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Kann es sein, dass das Programm nicht mit Java 1.5 kompatibel ist?

    MFG

    Dennis
     
  4. #3 Edward Nigma, 12.01.2006
    Edward Nigma

    Edward Nigma root of all Evil

    Dabei seit:
    30.08.2003
    Beiträge:
    1.192
    Zustimmungen:
    0
    Ort:
    Leipzig
    Trag mal in die Datei .bash_profile in deinem /home-Ordner folgendes ein

    Code:
    PATH=/usr/local/jre1.5.0_06/bin:$PATH:$HOME/bin
     
  5. munuel

    munuel Eroberer

    Dabei seit:
    11.09.2004
    Beiträge:
    53
    Zustimmungen:
    0
    Hallo,
    Ich bin unter SuseLinux 9.3 (hab ich vergessen zu sagen)!
    Und eine .bash_profile hab ich nicht!

    Aber in meiner .bashrc hab ich folgendes :

    PHP:
    export PATH="$PATH:/usr/java/jdk1.5.0_06/bin"
    Die Java Befehle (java, javac) lassen sich ja auch ausfürhen auf der Shell!
    Leider hab ich noch keine Docu zu dem Programm gefunden, ist ein Treiber für einen Drucker.
    jdk1.5 ist doch relativ neu und sollte abwärtskompatibel sein, oder kann es da
    zu Problemen kommen?

    Viele Grüsse munuel
     
Thema:

Abruch von Java - Programm mit Fehlermeldung

Die Seite wird geladen...

Abruch von Java - Programm mit Fehlermeldung - Ähnliche Themen

  1. Abruch Startvorgang OpenOffice

    Abruch Startvorgang OpenOffice: Leider startet keine openoffice-Anwendung mehr auf meinem etch. Auch /home/user/.openoffice2.org habe ich gelöscht und das starten als root...
  2. emerge-Abruch bei xorg/x11

    emerge-Abruch bei xorg/x11: Hi, wie der Titel schon sagt, scheitert emerge daran xorg zu emergen und ich habe keine Ahnung warum. Hier mal der emerge-output wenn ich...
  3. Java-Anwendungsserver: WildFly 10 freigegeben

    Java-Anwendungsserver: WildFly 10 freigegeben: Der Java-Anwendungsserver WildFly ist in Version 10 erschienen. Die neue Version ist nur noch für Java 8 und 9 ausgelegt und kann unter anderem...
  4. Java Plug-in geht in Rente

    Java Plug-in geht in Rente: Oracle hat angekündigt, mit der Auslieferung von Java 9, das frühestens im Frühjahr 2017 erscheinen soll, das Java-Browser-Plug-in als veraltet zu...
  5. Quellcode der JavaScript-Engine Chakra freigegeben

    Quellcode der JavaScript-Engine Chakra freigegeben: Microsoft hat die Kernkomponenten der JavaScript-Engine Chakra wie angekündigt freigegeben. Unterstützung für Linux ist eines der vordringlichsten...