Abhängigkeiten unbehebar auch mit apt-get -f install

Dieses Thema im Forum "Installation & Basiskonfiguration" wurde erstellt von Brainhead, 30.12.2007.

  1. #1 Brainhead, 30.12.2007
    Brainhead

    Brainhead Jungspund

    Dabei seit:
    18.07.2007
    Beiträge:
    11
    Zustimmungen:
    0
    Hallo Leute,

    Ich hab ein Problem. Undzwar macht hier das Paktet libbost regex ein paar Probleme, hat also nicht erfüllte Abhängigkeiten. apt-get -f install scheitert auch:

    Code:
    Vorbereiten zum Ersetzen von libboost-regex1.34.1 1.34.1-2 (durch .../libboost-regex1.34.1_1.34.1-4_i386.deb) ...
    Entpacke Ersatz für libboost-regex1.34.1 ...
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libboost-regex1.34.1_1.34.1-4_i386.deb (--unpack):
     Versuche, Verzeichnis »/usr/lib/libboost_regex-gcc42-1_34_1.so.1.34.1« in Paket libboost-regex1.34.1-2 mit Nichtverzeichnis zu überschreiben
    dpkg-deb: Unterprozess paste mit Signal (Datenübergabe unterbrochen (broken pipe)) getötet
    Fehler traten auf beim Bearbeiten von:
     /var/cache/apt/archives/libboost-regex1.34.1_1.34.1-4_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Ich habe schon vieles Versucht, aber leider hat nichts funktioniert. Weiß jemand Rat?

    Vielen Dank.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Tomekk228, 30.12.2007
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
  4. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    So wie ich das verstehe ist bereits eine Version des Pakets installiert, die nun komplett überschrieben werden soll. Das installierte Paket hat ein Verzeichnis /usr/lib/libboost_regex-gcc42-1_34_1.so.1.34.1 angelegt, dass überschrieben werden soll.
    Das neue Paket legt an diese Stelle aber kein Verzeichnis. Was eigentlich auch korrekt aussieht...

    Ein Versuch wäre es das bereits installierte Paket zu entfernen (eventuell ohne dependencies) und dann das neue zu installieren.
    - ich gebe keine Garantie, dass danach noch etwas läuft ;-)
     
  5. #4 Brainhead, 30.12.2007
    Brainhead

    Brainhead Jungspund

    Dabei seit:
    18.07.2007
    Beiträge:
    11
    Zustimmungen:
    0
    Ja hab ich mir auch gedacht, ich hatte boost selber kompiliert und anscheinend einmal über apt installiert.

    /usr/lib/libboost_regex-gcc42-1_34_1.so.1.34.1 <den Ordner gibt es nicht .

    Naja ich versuchs mal, danke für eure Antworten.
     
  6. #5 Brainhead, 31.12.2007
    Brainhead

    Brainhead Jungspund

    Dabei seit:
    18.07.2007
    Beiträge:
    11
    Zustimmungen:
    0
    Hab es selber gelöst, indem ich einfach erstmal die quelle von boost in der sources.list auskommentiert und danach apt-get -f install eingegeben habe, dann ging alles von selber.
     
Thema:

Abhängigkeiten unbehebar auch mit apt-get -f install

Die Seite wird geladen...

Abhängigkeiten unbehebar auch mit apt-get -f install - Ähnliche Themen

  1. Wer kann mir eine Info zu Abhängigkeiten unter Kubuntu 14.04 geben ?

    Wer kann mir eine Info zu Abhängigkeiten unter Kubuntu 14.04 geben ?: Kann mir Jemand eine Information zu Abhängigkeiten unter Kubuntu 14.04 geben ? Es geht um das Paket Libavcodec-extra-54 , da steht in der...
  2. CrossOver 14.0 installiert Abhängigkeiten automatisch

    CrossOver 14.0 installiert Abhängigkeiten automatisch: CrossOver 14.0 von CodeWeavers, das auf Wine 1.7.25 basiert, bringt für Linux eine neue automatische Konfiguration, die Systemkomponenten...
  3. Debian vertraut Paketbetreuern in Sachen Systemd-Abhängigkeiten

    Debian vertraut Paketbetreuern in Sachen Systemd-Abhängigkeiten: Der technische Ausschuss von Debian (CTTE) hat in einer zweiten Abstimmungsrunde beschlossen, derzeit keine Regel zu erlassen, die bestimmt, ob...
  4. RPM Abhängigkeiten zusammenstellen und herunterladen

    RPM Abhängigkeiten zusammenstellen und herunterladen: Hallo liebe Unixboard-Gemeinde, ich habe einen CentOS-Server in einer Zone ohne Zugang zum Internet stehen und muss dort die Pakete...
  5. abhängigkeiten NICHT auflösen

    abhängigkeiten NICHT auflösen: Hi, ich hab ne kommerzielle Software unter Debian 6 laufen, die eigentlich fuer Debian 5 gemacht wurde. Sie ist gegen libmotif3 gelinkt. Debian...