9.1+Nvidia

Dieses Thema: "9.1+Nvidia" im Forum "Mandriva" wurde erstellt von Algi, 28.03.2003.

  1. Algi

    Algi Jungspund

    Dabei seit:
    16.02.2003
    Beiträge:
    17
    Zustimmungen:
    0
    Ort:
    NRW/Oberhausen
    Hi!
    Wollte mir auf mdk 9.1 den nvidia treiber aufziehen. Habe mir die kernel und glx src geladen...wenn ich allerdings die kernel entpacke und als root "make" eingebe bekomme ich folgende Fehlermeldung:
    Code:
    [root@localhost NVIDIA_kernel-1.0-4191]# make
    cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar  -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=4191  -DNV_UNIX   -DNV_LINUX   -DNV_INT64_OK   -DNVCPU_X86       -I. -I/usr/src/linux/include -Wno-cast-qual nv.c
    In file included from /usr/include/linux/prefetch.h:13,
                     from /usr/include/linux/list.h:6,
                     from /usr/include/linux/module.h:11,
                     from nv-linux.h:28,
                     from nv.c:14:
    /usr/include/asm/processor.h:55: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
    /usr/include/asm/processor.h:55: requested alignment is not a constant
    In file included from /usr/include/linux/module.h:297,
                     from nv-linux.h:28,
                     from nv.c:14:
    /usr/include/linux/version.h:2:2: #error "======================================================="
    /usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
    /usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
    /usr/include/linux/version.h:5:2: #error ""
    /usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
    /usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
    /usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
    /usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
    /usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
    /usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
    /usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
    /usr/include/linux/version.h:13:2: #error ""
    /usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
    /usr/include/linux/version.h:15:2: #error ""
    /usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
    /usr/include/linux/version.h:17:2: #error ""
    /usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
    /usr/include/linux/version.h:19:2: #error "   /lib/modules/`uname -r`/build exists and points to"
    /usr/include/linux/version.h:20:2: #error "   the matching kernel source directory"
    /usr/include/linux/version.h:21:2: #error ""
    /usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
    /usr/include/linux/version.h:23:2: #error "   /lib/modules/`uname -r`/build/include/linux/version.h"
    /usr/include/linux/version.h:24:2: #error ""
    /usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
    /usr/include/linux/version.h:26:2: #error "   compiler option to use the correct include files:"
    /usr/include/linux/version.h:27:2: #error ""
    /usr/include/linux/version.h:28:2: #error "   -I/lib/modules/`uname -r`/build/include"
    /usr/include/linux/version.h:29:2: #error ""
    /usr/include/linux/version.h:30:2: #error "   instead of"
    /usr/include/linux/version.h:31:2: #error ""
    /usr/include/linux/version.h:32:2: #error "   -I/usr/include/linux"
    /usr/include/linux/version.h:33:2: #error ""
    /usr/include/linux/version.h:34:2: #error "   Please adjust the Makefile accordingly."
    /usr/include/linux/version.h:35:2: #error "======================================================="
    In file included from nv-linux.h:28,
                     from nv.c:14:
    /usr/include/linux/module.h:299: parse error before "UTS_RELEASE"
    /usr/include/linux/module.h: In function `print_symbol':
    /usr/include/linux/module.h:433: `ESRCH' undeclared (first use in this function)
    /usr/include/linux/module.h:433: (Each undeclared identifier is reported only once
    /usr/include/linux/module.h:433: for each function it appears in.)
    In file included from nv-linux.h:29,
                     from nv.c:14:
    /usr/include/linux/version.h:2:2: #error "======================================================="
    /usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
    /usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
    /usr/include/linux/version.h:5:2: #error ""
    /usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
    /usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
    /usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
    /usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
    /usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
    /usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
    /usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
    /usr/include/linux/version.h:13:2: #error ""
    /usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
    /usr/include/linux/version.h:15:2: #error ""
    /usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
    /usr/include/linux/version.h:17:2: #error ""
    /usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
    /usr/include/linux/version.h:19:2: #error "   /lib/modules/`uname -r`/build exists and points to"
    /usr/include/linux/version.h:20:2: #error "   the matching kernel source directory"
    /usr/include/linux/version.h:21:2: #error ""
    /usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
    /usr/include/linux/version.h:23:2: #error "   /lib/modules/`uname -r`/build/include/linux/version.h"
    /usr/include/linux/version.h:24:2: #error ""
    /usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
    /usr/include/linux/version.h:26:2: #error "   compiler option to use the correct include files:"
    /usr/include/linux/version.h:27:2: #error ""
    /usr/include/linux/version.h:28:2: #error "   -I/lib/modules/`uname -r`/build/include"
    /usr/include/linux/version.h:29:2: #error ""
    /usr/include/linux/version.h:30:2: #error "   instead of"
    /usr/include/linux/version.h:31:2: #error ""
    /usr/include/linux/version.h:32:2: #error "   -I/usr/include/linux"
    /usr/include/linux/version.h:33:2: #error ""
    /usr/include/linux/version.h:34:2: #error "   Please adjust the Makefile accordingly."
    /usr/include/linux/version.h:35:2: #error "======================================================="
    In file included from nv.c:14:
    nv-linux.h:31:40: missing binary operator before '('
    nv-linux.h:33:42: missing binary operator before '('
    nv-linux.h:35:42: missing binary operator before '('
    nv-linux.h:37:42: missing binary operator before '('
    nv-linux.h:39:42: missing binary operator before '('
    nv-linux.h:43:4: #error This driver does not support 2.6.x or newer kernels!
    In file included from /usr/include/asm/hardirq.h:6,
                     from /usr/include/linux/interrupt.h:46,
                     from nv-linux.h:71,
                     from nv.c:14:
    /usr/include/linux/irq.h: At top level:
    /usr/include/linux/irq.h:65: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
    /usr/include/linux/irq.h:65: requested alignment is not a constant
    In file included from /usr/include/linux/interrupt.h:46,
                     from nv-linux.h:71,
                     from nv.c:14:
    /usr/include/asm/hardirq.h:16: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
    /usr/include/asm/hardirq.h:16: requested alignment is not a constant
    In file included from nv-linux.h:71,
                     from nv.c:14:
    /usr/include/linux/interrupt.h:129: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
    /usr/include/linux/interrupt.h:129: requested alignment is not a constant
    nv-linux.h:184:64: missing binary operator before '('
    nv.c:1335:65: missing binary operator before '('
    nv.c: In function `nv_kern_mmap':
    nv.c:1338: warning: implicit declaration of function `pgprot_writecombine'
    nv.c:1338: incompatible types in assignment
    make: *** [nv.o] Fehler 1
    
    weis leider nicht woran es liegt...plz help me:(
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Maerel

    Maerel Zensiert

    Dabei seit:
    15.01.2003
    Beiträge:
    180
    Zustimmungen:
    0
    Ort:
    /home/maerel
    Du hast die Kernel sourcen nicht installiert.

    Starte einfach rpmdrake und installiere sie
    nach.
    Das Paket heißt: kernel-source-2.4.21-0.13mdk
     
  4. Algi

    Algi Jungspund

    Dabei seit:
    16.02.2003
    Beiträge:
    17
    Zustimmungen:
    0
    Ort:
    NRW/Oberhausen
    thx=) funzt alles:D
     
Thema:

9.1+Nvidia