> 40 Sek. bis zur Grub-Betriebssystem Auswahl

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von hydra, 01.09.2005.

  1. hydra

    hydra praetorian

    Dabei seit:
    29.01.2003
    Beiträge:
    37
    Zustimmungen:
    0
    Ort:
    AUSTRIA - CARINTHIA
    Einen wunderschönen Guten Morgen!

    Mein Dual-Boot-System (Kubuntu Hoary 5.04 und Windows XP) braucht mehr als 40 Sekunden vom Drücken des Einschaltknopfes bis zur GRUB-Betriebssystem-Auswahl.

    Erstmal glaubt man das System hängt beim Booten, dann nach 25 sek kommt
    Code:
    Grub loading stage 1.5
    und nach weiteren 15 Sekunden erst die Auswahl.

    Die letzten Dinge die ich an meinem System verändert habe, vorher lief es makellos, waren dass ich VMWare installiert habe und eine Windows Partition mittels fdisk von FAT32(Hidden) auf FAT32 (LBA) geändert habe.
    Hab die Partition dann Mal auch auf FAT32 Normal geändert, jedoch ohne Wirkung.
    Hängt es ev. damit irgendwie zusammen?

    Hat irgendwer eine Idee warum der Grub so lange braucht? ?(

    Danke für die Antworten.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 illtiss, 01.09.2005
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Was steht denn in deiner grub.conf, und Device.map?
     
  4. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Ein paar zusätzliche Infos wären echt brauchbar. Wie sieht deine /boot/grub/menu.lst aus? Was steht in der /boot/grub/device.map? Hast du Grub in den MBR installiert? Benutzt du irgendwelche bunten Bildchen um deinen Grub zu verschönern?
     
  5. hydra

    hydra praetorian

    Dabei seit:
    29.01.2003
    Beiträge:
    37
    Zustimmungen:
    0
    Ort:
    AUSTRIA - CARINTHIA
    Hier die hoff. hilfreiche Info:

    GRUB ist in den MBR installiert und ich benutze keine bunten Bildchen um den Bootloader zu verschönern.

    device.map
    Code:
    (hd0)   /dev/hda
    menu.lst
    Code:
    # menu.lst - See: grub(8), info grub, update-grub(8)
    #            grub-install(8), grub-floppy(8),
    #            grub-md5-crypt, /usr/share/doc/grub
    #            and /usr/share/doc/grub-doc/.
    
    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.           
    default		0
    
    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout		10
    
    ## hiddenmenu
    # Hides the menu by default (press ESC to see the menu)
    #hiddenmenu
    
    # Pretty colours
    #color cyan/blue white/blue
    
    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line)  and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    #      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret
    
    #
    # examples
    #
    # title		Windows 95/98/NT/2000
    # root		(hd0,0)
    # makeactive
    # chainloader	+1
    #
    # title		Linux
    # root		(hd0,1)
    # kernel	/vmlinuz root=/dev/hda2 ro
    #
    
    #
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST
    
    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default optons below
    
    ## DO NOT UNCOMMENT THEM, Just edit them to your needs
    
    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specifiv kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    # kopt=root=/dev/hda6 ro
    
    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=(hd0,5)
    
    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ##      alternative=false
    # alternative=true
    
    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ##      lockalternative=false
    # lockalternative=false
    
    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ##      altoptions=(recovery mode) single
    # altoptions=(recovery mode) single
    
    ## nonaltoption boot targets option
    ## This option controls options to pass to only the
    ## primary kernel menu item.
    ## You can have ONLY one nonaltoptions line
    # nonaltoptions=quiet splash
    
    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ##      howmany=7
    # howmany=all
    
    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ##      memtest86=false
    # memtest86=true
    
    ## ## End Default Options ##
    
    title		Ubuntu, kernel 2.6.10-5-386 
    root		(hd0,5)
    kernel		/boot/vmlinuz-2.6.10-5-386 root=/dev/hda6 ro quiet splash
    initrd		/boot/initrd.img-2.6.10-5-386
    savedefault
    boot
    
    title		Ubuntu, kernel 2.6.10-5-386 (recovery mode)
    root		(hd0,5)
    kernel		/boot/vmlinuz-2.6.10-5-386 root=/dev/hda6 ro single
    initrd		/boot/initrd.img-2.6.10-5-386
    savedefault
    boot
    
    title		Ubuntu, kernel memtest86+ 
    root		(hd0,5)
    kernel		/boot/memtest86+.bin  
    savedefault
    boot
    
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    
    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title		Other operating systems:
    root
    
    
    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/hda1
    title		Microsoft Windows XP Professional
    root		(hd0,0)
    savedefault
    makeactive
    chainloader	+1
    
    Könnt ihr Fehler erkennen?
     
  6. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Also ich sehe da erstmal keinen Fehler. Versuche mal ein 'grub-install /dev/hda' (also eine Reinstallation des GRUB) und schau, ob sich das verhalten ändert. Ansonsten solltest du mal deine Festplatte und deinen Speicher durchchecken ob Hardware-seitig alles in Ordnung ist.
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. wurmus

    wurmus Tripel-As

    Dabei seit:
    23.02.2004
    Beiträge:
    194
    Zustimmungen:
    0
    Ort:
    Laubach/hessen
    vielleicht liegt es ja am Bios
    ich hatte das problem bis eben auch noch und da hab ich ma im Bios geguckt da waren ganz andere Platten noch gelistet als mittlerweile drinnen sind

    also alle ide dings auf auto stellen dann sollte es gehen

    ~wurmus~
     
  9. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Ort:
    D -> BW -> Karlsruhe
    Zum einen brauch GRUB lange, wenn in den CD-Laufwerken ne Scheibe drinnenliegt, was sich schonmal zeitlich bemerkbar machen kann. Allerdings sind 40 Sekunden+ schon eher ein Anzeichen dafür, dass die Superblock-Einträge Deiner Platte langsam aber sicher den Bach runter gehen, das wiederum kann ein Anzeichen dafür sein, dass evtl. auch die Platte bald hin ist.

    Ich hatte das gleiche phänomen, ausgelöst durch Plattenzugriffe im dma-modus. Sieht man alles schon inder /var/log/messages. Das abschalten brachte dann zwar keine Fehler mehr zutage, die Zugriffe wurdfen langsamer, die Blöcke waren dennoch hinüber.
    Erst nachdem ich die Platte dann man genullt hatte gings wieder.

    Da das alles aber nicht zufriedenstellend war, hab ich kurzerhand ne neue HD besorgt und eingebaut. Seitdem ist ruhe, DMA ist an und die Kiste rennt wieder wie sau.
     
Thema:

> 40 Sek. bis zur Grub-Betriebssystem Auswahl

Die Seite wird geladen...

> 40 Sek. bis zur Grub-Betriebssystem Auswahl - Ähnliche Themen

  1. Mozilla kritisiert Änderung der Browser-Auswahl in Windows 10

    Mozilla kritisiert Änderung der Browser-Auswahl in Windows 10: Microsoft verweigert in Windows 10 den Benutzern die freie Wahl des Webbrowsers und überschreibt die vorhandene Auswahl ungefragt und mit jeder...
  2. CentOS 7 Grafikkarte auswählen

    CentOS 7 Grafikkarte auswählen: Hallo Zusammen, ich bin neu hier und auch neu in der Linux-Welt und möchte erstmal alle begrüßen. Nun zu meinem Problem: Ich habe zuhause...
  3. Artikel: Linux-Distributionen für spezielle Fälle: Eine kleine Auswahl

    Artikel: Linux-Distributionen für spezielle Fälle: Eine kleine Auswahl: Im folgenden Artikel erhalten Sie einen Überblick über wichtige Linux-Spezialsysteme. Diese sind größtenteils nicht als installierbare Systeme...
  4. Gnome: Neues Designkonzept für Auswahl und Kopieren

    Gnome: Neues Designkonzept für Auswahl und Kopieren: Bereits seit zwei Jahren tragen sich die Entwickler damit, die Funktion der mittleren Maustaste zu verändern. Nun könnte schon bald die...
  5. Auswahl Serverbetriebssystem

    Auswahl Serverbetriebssystem: Hallo Community, ich komme mal wieder mit einer alten Frage daher, die für mich gerade aktuell ist. Ich habe mir einen virtuellen Linux-Webserver...