3d von hand aktivieren ?

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Morning85, 18.07.2006.

  1. #1 Morning85, 18.07.2006
    Zuletzt bearbeitet: 18.07.2006
    Morning85

    Morning85 Jungspund

    Dabei seit:
    17.07.2006
    Beiträge:
    24
    Zustimmungen:
    0
    da mein sax2 aus welchem grund auch immer zerschossen ist und nicht merh startet, möchte ich nun die 3d beschleunigung von hand aktivieren. how to do that ?

    habe meinen treiber für die Radeon 9600 sauberst installiert, runlevel 3 , alles lief prima. (siehe meinen anderen thread)

    habe die xorg config so eingestellt, dass sie den treiber lädt, jetzt fehlt nur noch ein schritt: die 3d beschleunigung. da ich SaX2 nicht starten kann ,frag ich mich, wie ich sie von hand aktiviere.

    vielleicht kann mir auch jemand sagen, wie ich Sux...äh...SaX2 repariere

    entschuldigt, dass ich einen neuen thread erstellt habe, aber ich denke, den alten wird niemand mehr lesen, da ich die neusten ergebnisse rein-editiert habe, und nicht per reply hinzugefügt habe

    fglrx info output:

    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
    .


    der ati treiber ist defintiv SAUBER installiert. das hat mich zwar viel zeit & nerven gekostet, aber es ließe sich wenigstens mit logik lösen, nicht so das jetzige problem, mit dem Sax 2
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    In deiner /etc/X11/xorg.conf muß als "driver fglrx" stehen ... dann haste schonmal nen wichtige Schritt in die richtige Richtung unternommen ;)

    Es gibt auch das aticonfig Tool ... ruf es einfach mal auf ;)
     
  4. #3 Morning85, 18.07.2006
    Morning85

    Morning85 Jungspund

    Dabei seit:
    17.07.2006
    Beiträge:
    24
    Zustimmungen:
    0
    alles ausprobiert

    nun: X11 zerschossen.

    warum: xorg.conf editiert und eine sektion rausgenommen. auch versuche wiederherzustellen: erfolglos

    heute abend: neuinstallation (die dritte)



    aticonfig: alles ausprobiert, führt zu nichts, oder habe ich was übersehen ? wo aktiviert man da 3dunterstützung ?


    danke und danke im vorraus für kommende antworten

    ein extrem frustrierter morning auf 180 X(
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    X11 hast du sicherlich nicht zerschossen ... was kommt denn für eine Meldung wenn du sax2 aufrufst ?
    (Bist du auch im Runlevel 3 wenn du sax aufrufen willst ? - init 3)
     
  6. #5 Morning85, 18.07.2006
    Zuletzt bearbeitet: 18.07.2006
    Morning85

    Morning85 Jungspund

    Dabei seit:
    17.07.2006
    Beiträge:
    24
    Zustimmungen:
    0
    egal jetzt - bin schon am neuinstallieren (ich hatte wie gesagt die xorg.conf kaputt gemacht)

    wichtiger isses die 3d unterstützung zu aktivieren :=)

    und wenn ich sax aufrufen will komtm eben gar keine meldung, d.h. wenn cihs von gnome aus starte, lädt er erst die module und was weiß ich und dann passiert rein garnichts mehr. dasselbe spiel von der konsole. fehlermeldungen - keine !!!!!

    als ich sax auf runlevel 3 aufgeruft habe, hat es normal gestartet, und dann meinen treiber komisch unkonfiguriert, so, als hätte ich ihn auf runlevel 5 installiert. darauf hin treiber neu -> immernoch das selbe problem mit SuX. dann hand angelegt -> X11 ganz kaputt. jetzt installier ich grade neu (bin mitm andern pc online)
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Sichere dir doch die xorg.conf bevor du sowas machst ;)

    Code:
    cp xorg.conf xorg.conf.backup
    

    Ich gehe jede Wette ein das der Fehler nich am SuSE/Treiber lag ;)
     
  8. #7 Morning85, 18.07.2006
    Zuletzt bearbeitet: 18.07.2006
    Morning85

    Morning85 Jungspund

    Dabei seit:
    17.07.2006
    Beiträge:
    24
    Zustimmungen:
    0
    habe ich, habe ich, habe. habe gebackupt. auch die gebackupped hat keine besserung gezeigt. vielleicht hats auch andere dateien zerschossen...keine ahnung. linux halt ;) wurscht nu, linux steht wieder!

    nur wie installier ich den treiber so, dass es endlich geht ?? woran liegt der fehler denn ? help meeeee !! :(

    status quo:

    SuX lädt nicht, driver steht auf fglrx, ...

    soll ich fglrx auch bei "Modules" eintragen alos

    load "fglrx" ?


    hier meine xorg.conf

    *seufz*
    ich wünschte, jemand liest das und sagt: AAH, genau dORT liegt des pudels kern, und es würde endlich funzen, dass ich WoW zocken kann


    warum liebe jungs von ATI, könnt ihr nicht einfach einen treiber machen, der einfach nur FUNKTIONIERT ? ich meine, selbst auf meinem Notebook funktioniert der 3D treiber (Nvidia)

    kann mal bitte jemand was posten, damit ich meine xorg.log datei reinpasten kann ? irgendwie scheint das hier nicht mehr zu gehen, weils sonst zu groß wird oder so

    ich sehe übrigens auch gerade, dass er im hardware-manager die karte als "PCI" einstuft. falls das was zur sache tut...


    hier eine vll interessante stelle der xorg log datei

     
  9. Horus

    Horus Doppel-As

    Dabei seit:
    08.06.2005
    Beiträge:
    138
    Zustimmungen:
    0
  10. #9 Morning85, 19.07.2006
    Zuletzt bearbeitet: 19.07.2006
    Morning85

    Morning85 Jungspund

    Dabei seit:
    17.07.2006
    Beiträge:
    24
    Zustimmungen:
    0
    danke vielmals horus :)

    aber wie das bei den ati treibern so ist: jede lösung - ein neuer fehler !

    jetzt also kann ich sax laden. und, jep, da is sogar ein häkchen bei 3d-beschleunigung. so weit so schlecht. natürlich ist die 3d beschelunigung immernoch nicht funktionstüchtig.

    und natürlich gibt fglrxinfo immernoch die mesa-kacke anstatt des ati-treibers aus.

    noch vorschläge ? habe jetzt alle howtos auf der linux-club seite durchgearbeitet, und so langsam aber sicher glaube ich, dass dieses problem unlösbar ist -.-

    hier die neue Device Sektion#

    aber immerhin: schonmal ein schritt weiter... :)


    achja

    die stelle im xorg log is immernoch beim alten:

    kann irgendjemand damit was anfangen ?
     
  11. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Ich sagte dir schonmal im IRC - poste mal die Meldung beim Modul laden:

    Code:
    dmesg | grep fglrx
    
    Dann verstehst du auch irgendwann WO dein Problem liegt ;)
     
  12. #11 Morning85, 19.07.2006
    Zuletzt bearbeitet: 19.07.2006
    Morning85

    Morning85 Jungspund

    Dabei seit:
    17.07.2006
    Beiträge:
    24
    Zustimmungen:
    0
    naja, das gibt ja einen teil der /var/log/xorg0.log aus

    was ich als anfänger nun rauslese ist (das kommt sowohl mit als auch ohne AGPGART), dass der fglrx-treiber nicht mit dem kernel harmoniert. wie genau, kann ich nicht sagn, da ich weder weiß wie der kernel aufgebaut ist, noch was die beidesn "ERROR" im einzelnen bedeuten. weiterhin vermute ich, dass es mit der AGP unterstützung im Kernel zusammenhängt.

    ist meine annahme sowiet richtig?

    folgendes, habe ich in einer FAQ gefunden:

    mein problem: wo liegt die kernel config file, bzw. wie heißt sie?
     
  13. polka

    polka Mitglied

    Dabei seit:
    16.07.2006
    Beiträge:
    33
    Zustimmungen:
    0
    Soweit ich weiss lässt sich die 3d beschleunigung bei ati radeon nicht uber sax einstellen, sondern sollte nach korrekter installation funktionieren. fglrxinfo sollte als renderer statt mesa deine graka angeben.
    Bearbeite deine xorg am besten nochmal neu.
    aticonfig --initial --input=/etc/X11/xorg.conf
    und danach
    init 3
    sax2 -r -m 0=fglrx
    danach fglrxinfo und guck ob mesa als renderer steht und schreib wieder...
     
  14. #13 Morning85, 22.07.2006
    Morning85

    Morning85 Jungspund

    Dabei seit:
    17.07.2006
    Beiträge:
    24
    Zustimmungen:
    0
    danke dir, aber alles schon probiert und jup, immer noch das mesa
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. rasade

    rasade Eroberer

    Dabei seit:
    22.03.2004
    Beiträge:
    71
    Zustimmungen:
    0
    Ort:
    Runkel
    ATI installieren

    .. deine xorg.conf zeigt eine rv350, benutze doch mal diese libGL:

    http://www.ground-impact.com/libGL.so.1.2

    bei mir hat's geholfen.

    Gruß
    Rainer
     
  17. #15 XXXXXXXXX, 22.07.2006
    XXXXXXXXX

    XXXXXXXXX GESPERRT!

    Dabei seit:
    15.07.2006
    Beiträge:
    58
    Zustimmungen:
    0
    Hallo,

    machs mal total anders. Ich hatte die selben Problem wie du, und jetzt läuft meine 3D Karte auch mit ner Widerholfrequenz von 85Hz.

    Also Schritt für Schirtt!

    1. Ab ins Yast
    -> Software installieren oder löschen. Bitte gucken ob die die folgende Pakete hinzugefügt hast: Kernel Source, GCC und make.

    2. ATI Treiber runterladen
    Wenn du den Treiber runter geladen hast, dann mit rechter Maustraste drauf und dann auf Eigenschaften. -> Datei ausführbar machen.

    3. Installieren
    Konsole aufrufen, su eingeben -> dann die Datei einfach aufrufen: atixxxxx.run. Es startet anschießend die grafische Installation, immer auf weiter...

    4. Nach der Installation
    Konsole su, dann init 3 dann aticonfig --initial (Wenn der Befehl nitt funtzt dann:) aticonfig --initial --input(etc/X11/xorg.conf)

    5. Neustart
    Nach dem Neustart ist deine 3D Unterstützung da.

    Wichtig:
    Machs mit einem Frischen System wo du den Kernel noch nicht geupdatet hast... ohne KernelSource kannst du des vergessen!!! Da nach kannst du dir die Xorg noch für die Wiederhohlfrequenzen anpassen.

    Hier mal meine:

    PHP:

    # /.../
    # SaX generated X11 config file
    # Created on: 2006-07-21T21:11:58+0200.
    #
    # Version: 7.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (7.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
        
    Identifier     "Layout[all]"
        
    Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    
    "Keyboard[0]" "CoreKeyboard"
        
    InputDevice    "Mouse[1]" "CorePointer"
        
    Option        "Clone" "off"
        
    Option        "Xinerama" "off"
    EndSection

    Section 
    "Files"
        
    InputDevices   "/dev/gpmdata"
        
    InputDevices   "/dev/input/mice"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/misc:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/local"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/URW"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/Speedo"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/PEX"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/latin2/Type1"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/kwintv"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/truetype"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/uni:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/CID"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/hellas/Type1"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
        
    FontPath     "/usr/X11R6/lib/X11/fonts/xtest"
        
    FontPath     "/opt/kde3/share/fonts"
    EndSection

    Section 
    "Module"
        
    Load  "dbe"
        
    Load  "type1"
        
    Load  "freetype"
        
    Load  "extmod"
        
    Load  "glx"
        
    Load  "v4l"
        
    Load  "dri"
    EndSection

    Section 
    "ServerFlags"
        
    Option        "AllowMouseOpenFail" "on"
    EndSection

    Section 
    "InputDevice"
        
    Identifier  "Keyboard[0]"
        
    Driver      "kbd"
        
    Option        "Protocol" "Standard"
        
    Option        "XkbLayout" "de"
        
    Option        "XkbModel" "pc105"
        
    Option        "XkbRules" "xfree86"
        
    Option        "XkbVariant" "nodeadkeys"
    EndSection

    Section 
    "InputDevice"
        
    Identifier  "Mouse[1]"
        
    Driver      "mouse"
        
    Option        "Buttons" "11"
        
    Option        "Device" "/dev/input/mice"
        
    Option        "Name" "Microsoft IntelliMouse?? Explorer"
        
    Option        "Protocol" "explorerps/2"
        
    Option        "Vendor" "Sysp"
        
    Option        "ZAxisMapping" "4 5"
    EndSection

    Section 
    "Modes"
        
    Identifier     "Modes[0]"
        
    ModeLine     "1600x1200" 240.5 1600 1720 1896 2192 1200 1201 1204 1261
        ModeLine     
    "1600x1200" 237.7 1600 1720 1896 2192 1200 1201 1204 1261
        ModeLine     
    "1600x1200" 234.8 1600 1720 1896 2192 1200 1201 1204 1260
        ModeLine     
    "1280x1024" 192.9 1280 1376 1520 1760 1024 1025 1028 1085
        ModeLine     
    "1280x1024" 191.0 1280 1376 1520 1760 1024 1025 1028 1085
        ModeLine     
    "1280x1024" 188.9 1280 1376 1520 1760 1024 1025 1028 1084
        ModeLine     
    "1024x768" 155.4 1024 1104 1216 1408 768 769 772 830
        ModeLine     
    "1024x768" 154.1 1024 1104 1216 1408 768 769 772 829
        ModeLine     
    "1024x768" 152.9 1024 1104 1216 1408 768 769 772 829
        ModeLine     
    "800x600" 97.6 800 856 944 1088 600 601 604 650
        ModeLine     
    "800x600" 96.9 800 856 944 1088 600 601 604 650
        ModeLine     
    "800x600" 96.2 800 856 944 1088 600 601 604 650
    EndSection

    Section 
    "Monitor"
        
    Identifier   "Monitor[0]"
        
    VendorName   "STC"
        
    ModelName    "ALPHASCAN VIDEOSEVEN V7 N110S"
        
    UseModes     "Modes[0]"
        
    DisplaySize  370    280
        HorizSync    30.0 
    110.0
        VertRefresh  43.0 
    160.0
        Option        
    "DPMS"
    EndSection

    Section 
    "Monitor"
        
    Identifier   "aticonfig-Monitor[0]"
        
    Option        "VendorName" "ATI Proprietary Driver"
        
    Option        "ModelName" "Generic Autodetecting Monitor"
        
    Option        "DPMS" "true"
    EndSection

    Section 
    "Device"
        
    Identifier  "Device[0]"
        
    Driver      "radeon"
        
    VendorName  "ATI"
        
    BoardName   "RV350 AS"
        
    BusID       "1:0:0"
    EndSection

    Section 
    "Device"
        
    Identifier  "aticonfig-Device[0]"
        
    Driver      "fglrx"
    EndSection

    Section 
    "Screen"
        
    Identifier "Screen[0]"
        
    Device     "Device[0]"
        
    Monitor    "Monitor[0]"
        
    DefaultDepth     24
        SubSection 
    "Display"
            
    Depth     15
            Modes    
    "1600x1200" "1280x1024" "1024x768" "800x600"
        
    EndSubSection
        SubSection 
    "Display"
            
    Depth     16
            Modes    
    "1600x1200" "1280x1024" "1024x768" "800x600"
        
    EndSubSection
        SubSection 
    "Display"
            
    Depth     24
            Modes    
    "1600x1200" "1280x1024" "1024x768" "800x600"
        
    EndSubSection
        SubSection 
    "Display"
            
    Depth     8
            Modes    
    "1600x1200" "1280x1024" "1024x768" "800x600"
        
    EndSubSection
    EndSection

    Section 
    "Screen"
        
    Identifier "aticonfig-Screen[0]"
        
    Device     "aticonfig-Device[0]"
        
    Monitor    "aticonfig-Monitor[0]"
        
    DefaultDepth     24
        SubSection 
    "Display"
            
    Viewport   0 0
            Depth     24
            Modes    
    "1280x1024" "1024x768"
        
    EndSubSection
    EndSection

    Section 
    "DRI"
        
    Group        "video"
        
    Mode         0660
    EndSection
    Gruss Alex
     
Thema:

3d von hand aktivieren ?

Die Seite wird geladen...

3d von hand aktivieren ? - Ähnliche Themen

  1. [code]Text[/code] im Editor nicht mehr vorhanden

    [code]Text[/code] im Editor nicht mehr vorhanden: Hallo, früher gab es im Editor noch den Button für das erstellen von Code-Segmenten. Ich hab das für Konsolen-Output oder angabe von Befehlen...
  2. Ubuntu Phone als Vertragshandy in Deutschland

    Ubuntu Phone als Vertragshandy in Deutschland: Das Ubuntu Phone »Bq Aquaris E4.5 Ubuntu Edition« wird beim Elektronikhändler Saturn derzeit mit Vertrag für einen Euro angeboten. Ohne Vertrag...
  3. Gewinnspiel: »Linux - Das umfassende Handbuch« zu gewinnen

    Gewinnspiel: »Linux - Das umfassende Handbuch« zu gewinnen: Zum 20. Jubiläum des Buches »Linux - Das umfassende Handbuch« von Michael Kofler aus dem Rheinwerk Verlag verlost Pro-Linux zehn Exemplare des...
  4. »The Debian Administrator's Handbook« für Debian 8 »Jessie«

    »The Debian Administrator's Handbook« für Debian 8 »Jessie«: Die Autoren des Standardwerks zur Installation, Konfiguration und Administration von Debian haben das »Debian Administrator's Handbook« auf die...
  5. PDF: handout->presentation

    PDF: handout->presentation: Ich habe Vorlesungsfolien bloss als Handout-pdf's digital vorliegen, also 4 Slides per Seite. Ich finde das aber ziemlich unpraktisch, um auf dem...