3d Games und Xorg

Dieses Thema im Forum "Anwendungen" wurde erstellt von randomidiot, 04.01.2005.

  1. #1 randomidiot, 04.01.2005
    randomidiot

    randomidiot prolamer

    Dabei seit:
    02.08.2004
    Beiträge:
    155
    Zustimmungen:
    0
    Ort:
    Willytown
    Problem: Ich benutze gentoo und bin in der Gamesgruppe und bekomme ET und Doom3 nicht zum laufen. Wenn ich das Spiel starte passiert nichts, ausser das die Auflösung auf einmal niedriger ist. Ich bin ziemlich sicher das es an der xorg.conf liegt...
    Hier ist sie:



    Section "Files"
    RgbPath "/usr/X11R6/lib/X11/rgb"
    FontPath "/usr/share/fonts/local/"
    FontPath "/usr/share/fonts/misc/"
    FontPath "/usr/share/fonts/75dpi/:unscaled"
    FontPath "/usr/share/fonts/100dpi/:unscaled"
    FontPath "/usr/share/fonts/Type1/"
    FontPath "/usr/share/fonts/TTF/"
    FontPath "/usr/share/fonts/CID/"
    FontPath "/usr/share/fonts/Speedo/"
    FontPath "/usr/share/fonts/75dpi/"
    FontPath "/usr/share/fonts/100dpi/"
    ModulePath "/usr/X11R6/lib/modules"
    EndSection

    Section "Module"
    Load "dbe"
    SubSection "extmod"
    Option "omit xfree86-dga"
    EndSubSection
    Load "glx"
    Load "type1"
    Load "freetype"
    EndSection

    Section "ServerFlags"
    Option "blank time" "10"
    Option "standby time" "20"
    Option "suspend time" "30"
    Option "off time" "60"
    EndSection

    Section "InputDevice"
    Identifier "Cherry Cymotion Master Linux"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "de"
    Option "XkbVariant" "nodeadkeys"
    EndSection

    Section "InputDevice"
    Identifier "Razer Diamondback"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/input/mice"
    Option "Buttons" "9"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    Identifier "Medion 1998JB"
    HorizSync 30-98
    VertRefresh 50-160
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "GeForce FX 5700 LE"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "RenderAccel" "true"
    Option "NoLogo" "true"
    EndSection

    Section "Screen"
    Identifier "CRT"
    Device "GeForce FX 5700 LE"
    Monitor "Medion 1998JB"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1024x768"
    ViewPort 0 0
    EndSubsection
    SubSection "Display"
    Depth 16
    Modes "1024x768"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "800x600"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "640x480"
    EndSubSection
    SubSection "Display"
    Depth 1
    Modes "320x240"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "randoms layout"
    Screen "CRT"
    InputDevice "Razer Diamondback" "CorePointer"
    InputDevice "Cherry Cymotion Master Linux" "CoreKeyboard"
    EndSection

    will wieder ET spielen
    :)
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 traster, 04.01.2005
    traster

    traster Routinier

    Dabei seit:
    25.11.2003
    Beiträge:
    297
    Zustimmungen:
    0
    hi
    starte doch mal die games aus der konsole
    dann bekommst du vielleicht eine fehlermeldung
    (so ist es bei mir wenn das mit dem start meines aao passiert)
    mfg traster
     
  4. #3 randomidiot, 05.01.2005
    randomidiot

    randomidiot prolamer

    Dabei seit:
    02.08.2004
    Beiträge:
    155
    Zustimmungen:
    0
    Ort:
    Willytown
    Ups stimmt ja...
    Hier der Fehler:

    Xlib: extension "GLX" missing on display ":0.0".
    was bewirkt:
    Sys_Error: GLimp_Init() - could not load OpenGL subsystem

    Mist, glx wird doch mit X mitgeladen oder nicht?
    nvidia-glx ist jedenfalls emerged.

    Muss ich irgendwas beim Bootvorgang beachten?
     
  5. #4 traster, 05.01.2005
    traster

    traster Routinier

    Dabei seit:
    25.11.2003
    Beiträge:
    297
    Zustimmungen:
    0
  6. #5 NiceDay, 05.01.2005
    NiceDay

    NiceDay Aushilfe

    Dabei seit:
    17.05.2003
    Beiträge:
    1.314
    Zustimmungen:
    0
    Ort:
    Elmshorn
    .
     
  7. #6 randomidiot, 05.01.2005
    randomidiot

    randomidiot prolamer

    Dabei seit:
    02.08.2004
    Beiträge:
    155
    Zustimmungen:
    0
    Ort:
    Willytown
    öhm ja genau,
    ich weiss nicht was ich gemacht hab aber nu funktionierts ...
    ich habe nochmals nvidia-glx emerged und
    # opgengl-update nvidia
    gemacht + neustart

    Ha und jetzt funktionierts!
    war irgendwie nen dummer fehler von mir... ;)
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

3d Games und Xorg

Die Seite wird geladen...

3d Games und Xorg - Ähnliche Themen

  1. »OpenMandriva Games« gestartet

    »OpenMandriva Games« gestartet: Mit »OpenMandriva Games« haben die Entwickler der freien Distribution eine Plattform initiiert, die die Installation von Spielen auf der...
  2. LinuxGames schließt

    LinuxGames schließt: Nachdem sich bereits vor einiger Zeit mit »Happy Penguin« ein Veteran der Spieleseiten verabschiedete, kündigte nun auch LinuxGames.com die...
  3. Epic Games wird Blender-Sponsor

    Epic Games wird Blender-Sponsor: Epic Games, Entwickler der Unreal Engine, finanziert mit einer Einzelzuwendung von 10.000 Euro die Weiterentwicklung des freien 3D-Grafikprogramms...
  4. Online-Games welche laufen??

    Online-Games welche laufen??: Guten Tag alle zusammen, weiß nicht ob dies schon häufig gefragt wurde oder nicht, daher bitte nicht böse sein - bin ja schließlich erst seit...
  5. Lokaler Gameserver

    Lokaler Gameserver: Moin an alle, Ich hab ein Problem undzwar versuche ich gerade ein CS Server aufzusetzen, der läuft auch mitlerweile ganz gut nur zeigt er mir...