3 Soundkarten - Probleme mit Soundwiedergabe in Amarok, KDE, und co.

Dieses Thema im Forum "Sound" wurde erstellt von mightymike1978, 22.06.2006.

  1. #1 mightymike1978, 22.06.2006
    Zuletzt bearbeitet: 22.06.2006
    mightymike1978

    mightymike1978 Grünschnabel

    Dabei seit:
    09.06.2006
    Beiträge:
    4
    Zustimmungen:
    0
    Ort:
    Bonn, Nordrhein-Westfalen
    + + + + GELÖST + + + +

    Hi Leute,

    ich habe untenstehendes Problem durch eingehende Durchforstung der Documentation von www.alsa-project.org lösen können.

    Leider stand es nicht dort, wo es hätte stehen sollen... ;-)

    Das Problem lag an einer falschen Einstellung in der /usr/share/alsa/alsa.conf

    Bei mir soll ja die Soundkarte hw:0,0 laufen.

    In der alten Fassung meiner '"alsa.conf" stand dort im Abschnitt: " # defaults "
    sic!!!

    Nach Änderung in:
    funktioniert alles reibungslos!

    ROMA VICTOR!!!

    Achtung: Ich habe allerdings auch noch in den Verzeichnissen "/root/" und "/home/<benutzername>" eine .asoundrc mit folgendem Inhalt:
    angelegt.

    Ich vermute aber, dass die Änderung der alsa.conf mein Problem letztlich gelöst hat.

    -----

    Trotzdem hier meine Support-Anfrage:

    Hi Leute,

    ich setze Kubuntu Dapper Drake 6.0.6 LTS ein.

    Ich habe Probleme mit dem Sound!

    ich habe drei Soundkarten:

    snd-ice1712 M-Audio Delta 24/96
    snd-cs46xx Terrortec DMX 1024fire
    snd-via8235 onboard AC'97 Chip

    Allesamt für sich korrekt installiert ("# aplay <soundkarte Nr. 1 bis 3> wavedatei.wav" funktioniert bei jeder Karte!)

    Die Reihenfolge habe ich schon geändert. Die M-Audio wird nun im Programm "Infozentrum" nun korrekt als "Device 0" angezeigt.

    Aber irgendwie scheint sich Amarok gezielt immer die Onboard-Karte zu grapschen.

    Auch bei "# amixer"erscheint immer die Drecksonboard-Karte.

    Ich habe versucht in der "/etc/modprobe.d/alsa-base" die Reihenfolge zu erzwingen, aber das funktioniert nicht.

    Die Soundkarten funktionieren - jede für sich betrachtet - korrekt.

    Es kann auch kein Konflikt vorliegen, da lediglich eine einzige Andwendung auf den Sound zugreift.

    KMix zeigt die M-Audio als Hauptkarte an.

    Bitte teilt mir doch mal mit,
    in welcher Abhängigkeit
    in welchen Dateien ALSA-Module für KDE geladen werden.

    D.h. wo kann ich ALSA (bestenfalls system- und nicht nur nutzerweit) konfigurieren???

    Ich bin als erfahrener Windows-User und absoluter Linux Anfänger doch ein wenig irritiert...:think:

    Notfalls sagt mir, wie ich diese anderen Scheiss-Soundkarten deaktivieren kann!
    (Ich brauche sie aber unter Windows!!! Die Holzhammer-Methode Marke "Rausrupfen" ist nicht! :) )

    BTW: Im BIOS die Onboard-Karte zu deaktivieren würde mir bei 3 Soundkarten leider nix nutzen...

    Die m.E. relevanten Dateien habe ich Euch angehängt.

    Beste Grüße

    Michael

    PS:
    Zusatzfrage:
    Wieso kann ich in "Amarok" die Xine-Engine-Parameter nicht so umfassend ändern wie in "Kaffeine"?

    Für Suchmaschinen, falls Leute dasselbe Problem haben:
    Midiman delta-series, audiophile 2496, Amarok, Kaffeine, ALSA, XINE, Kubuntu, Arts, stumm, kein sound,
     

    Anhänge:

  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 theborg, 22.06.2006
    theborg

    theborg KBitdefender Programierer

    Dabei seit:
    06.08.2004
    Beiträge:
    688
    Zustimmungen:
    0
    Ort:
    Hamburg
    bei amarok kanste es mit der xine engin machen da auft alsa stellen oder oss dann kanste die soundkarte angeben z.b. /dev/dsp1
     
Thema:

3 Soundkarten - Probleme mit Soundwiedergabe in Amarok, KDE, und co.

Die Seite wird geladen...

3 Soundkarten - Probleme mit Soundwiedergabe in Amarok, KDE, und co. - Ähnliche Themen

  1. 2 Soundkarten /-treiber parallel

    2 Soundkarten /-treiber parallel: Hallo zusamm Mal wieder eine Frage: Gibt es eine Möglichkeit 2 Spundkarten gleichzeitig aktiviert zu haben und ihnen bestimmte Anwendungen...
  2. Zwei Soundkarten

    Zwei Soundkarten: Hallo, ich habe in meinem Rechner zwei Soundkarten eingebaut, die auch beide von Alsa erkannt wurden. Ich möchte, dass die Soundausgabe auf...
  3. ALSA und mehrere Soundkarten

    ALSA und mehrere Soundkarten: Hallo, ich habe ein Problem mit meinem Sound. Auf meiner Grafikkarte ist nämlich ein Soundchip verbaut (wegen HDMI/HDCP w/e Quark). Den brauche...
  4. Soundkarten wie ICH7 bzw. hda_intel

    Soundkarten wie ICH7 bzw. hda_intel: Für diejenigen, die Probleme mit der Soundkarte von Intel haben, die zur ICH7- Familie gehört bzw. die durch den Treiber snd_hda_intel...
  5. open suse 10.2: Soundkartentreiber

    open suse 10.2: Soundkartentreiber: Also ich bin von Win Vista auf OpenSuse 10.2 gewechselt. Ich habe zwar schon einen Linux recher der ununterbrochen rennt aber: Ich habe...